Description
The WP 2FA WordPress plugin before 4.2.0 does not perform an object-level capability check before removing a user's two-factor authentication configuration, allowing a site administrator on WordPress Multisite to remove the 2FA configuration of users outside their own site, including accounts they are not permitted to edit. On single-site installs an administrator can already manage all users, so this crosses a trust boundary only on Multisite.
Published: 2026-10-14
Score: 2.7 Low
EPSS: < 1% Very Low
KEV: No
Impact: Privilege Escalation
Action: Apply Patch
AI Analysis

Impact

The WP 2FA WordPress plugin before version 4.2.0 fails to perform an object‑level capability check when a user’s two‑factor authentication configuration is removed. This missing check allows an administrator with site‑admin rights on a WordPress Multisite network to delete or reset the 2FA settings of users belonging to sites outside the administrator’s own site, effectively eliminating that user’s second‑factor protection.

Affected Systems

This vulnerability affects installations of the WP 2FA plugin older than version 4.2.0 that run on a WordPress Multisite environment. Site‑admins who have the capability to manage users on their own subsites can exploit the flaw to modify 2FA settings for accounts on other subsites within the network. On single‑site WordPress deployments the flaw is not exploitable because administrators already have authority over all users.

Risk and Exploitability

The CVSS score of 2.7 indicates a low severity, and the EPSS score of less than 1 % suggests a low likelihood of exploitation. Not listed in CISA KEV, the vulnerability has not been reported as widely exploited. An attacker only needs authenticated site‑admin privileges on a Multisite deployment and can use the normal 2FA removal interface to remove other users’ MFA settings. No remote code execution or additional privileges are required; the attack vector is limited to authenticated use of the plugin’s user‑management interface.

Generated by OpenCVE AI on October 16, 2026 at 01:13 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade WP 2FA to version 4.2.0 or later.
  • Scope site‑admin roles so they cannot alter user 2FA configurations for users on other sites, for example by adjusting role capabilities or using a role‑management plugin.
  • Enable logging for 2FA configuration changes and regularly review logs for unauthorized modifications.

Generated by OpenCVE AI on October 16, 2026 at 01:13 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 17 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions wp 2fa
Vendors & Products Wordpress-extensions
Wordpress-extensions wp 2fa

Thu, 15 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-285 CWE-639
Metrics cvssV3_1

{'score': 2.7, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N'}


Wed, 14 Oct 2026 16:45:00 +0000

Type Values Removed Values Added
Weaknesses CWE-285

Wed, 14 Oct 2026 06:45:00 +0000

Type Values Removed Values Added
Description The WP 2FA WordPress plugin before 4.2.0 does not perform an object-level capability check before removing a user's two-factor authentication configuration, allowing a site administrator on WordPress Multisite to remove the 2FA configuration of users outside their own site, including accounts they are not permitted to edit. On single-site installs an administrator can already manage all users, so this crosses a trust boundary only on Multisite.
Title WP 2FA < 4.2.0 - Admin+ Arbitrary User 2FA Removal via IDOR
References

Subscriptions

Wordpress-extensions Wp 2fa
cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-15T10:32:08.873Z

Reserved: 2026-10-09T11:16:45.819Z

Link: CVE-2026-108066

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-14T07:17:02.303

Modified: 2026-10-15T11:17:19.510

Link: CVE-2026-108066

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-17T06:45:04Z

Weaknesses
  • CWE-639

    Authorization Bypass Through User-Controlled Key