Description
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Drupal Drupal core allows Reflection Injection. This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.
Published: 2026-10-30
Score: n/a
EPSS: n/a
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

This vulnerability allows an attacker to trigger PHP's reflection mechanism using externally supplied input that is not properly validated. By controlling the target class name, an attacker can cause arbitrary code execution from within the Drupal core, potentially giving full control over the compromised system. The weakness is a classic unsafe reflection flaw, matching CWE‑470, and it can be abused to execute malicious code without authentication if the attacker can reach a vulnerable input point.

Affected Systems

Drupal core is affected across a range of major releases. The vulnerable range includes all Drupal 8.9.x to 10.6.19, Drupal 11.0.0 through 11.3.19, Drupal 11.4.0 to 11.4.10, and the early releases of Drupal 12 from 12.0.0‑alpha1 up to 12.0.0‑beta2. Any site running one of these versions without the patch is at risk.

Risk and Exploitability

The alert is classified as a critical Remote Code Execution, but the EPSS score is not available, and the vulnerability is not listed in CISA’s KEV catalog, which makes precise exploitation probability difficult to gauge. However, due to the nature of the flaw—an unfiltered reflection call—any remote user who can invoke the vulnerable endpoint may trigger the attack. The advisory’s description underscores that the vulnerability is inherently high‑risk, and it is inferred that the attack vector is remote, likely via a crafted HTTP request to a Drupal endpoint that accepts class names from user input.

Generated by OpenCVE AI on October 30, 2026 at 04:29 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Drupal core to a patched release (at least 10.6.20, 11.3.20, 11.4.11, or 12.0.0‑beta3 or later).
  • Apply the vendor‑provided patch from the Drupal security advisory if an immediate full version upgrade cannot be performed.
  • After applying the fix, audit any custom modules or code that uses PHP reflection or dynamic class loading; ensure all such calls validate against a whitelist of approved class names to prevent re‑introduction of similar weaknesses.

Generated by OpenCVE AI on October 30, 2026 at 04:29 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

References
History

Fri, 30 Oct 2026 05:30:00 +0000

Type Values Removed Values Added
First Time appeared Drupal
Drupal drupal Core
Vendors & Products Drupal
Drupal drupal Core

Fri, 30 Oct 2026 03:30:00 +0000

Type Values Removed Values Added
Description Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Drupal Drupal core allows Reflection Injection. This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.
Title Drupal core - Critical - Remote code execution - SA-CORE-2026-014
Weaknesses CWE-470
References

Subscriptions

Drupal Drupal Core
cve-icon MITRE

Status: PUBLISHED

Assigner: drupal

Published:

Updated: 2026-10-30T03:09:55.043Z

Reserved: 2026-10-09T13:40:16.541Z

Link: CVE-2026-108097

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-30T04:18:04.130

Modified: 2026-10-30T04:18:04.130

Link: CVE-2026-108097

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T05:15:08Z

Weaknesses
  • CWE-470

    Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection')