Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in DLX Plugins Custom Query Blocks post-type-archive-mapping allows Stored XSS.This issue affects Custom Query Blocks: from n/a through 5.6.0.
Published: 2026-10-12
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored cross‑site scripting in the Custom Query Blocks plugin
Action: Patch immediately
AI Analysis

Impact

The vulnerability in the DLX Plugins Custom Query Blocks plugin is a stored cross‑site scripting flaw that allows an attacker to inject malicious scripts into web pages rendered by the site. This type of weakness (CWE‑79) means that any user who views the affected pages can have arbitrary JavaScript executed in their browser, potentially leading to session hijacking, credential theft, or defacement of content. The vulnerability can compromise confidentiality, integrity and availability of the site’s data for all visitors.

Affected Systems

The issue affects the DLX Plugins Custom Query Blocks plugin for WordPress. All installations using version 5.6.0 or earlier are vulnerable; the plugin is known to be distributed under the name Custom Query Blocks. No specific older versions are listed, so any earlier releases may also be affected.

Risk and Exploitability

The CVSS score is 6.5, indicating moderate severity. EPSS is not available, and the vulnerability is not listed in the CISA KEV catalog. The likely attack vector is through the plugin’s configuration interface that stores user input in the post‑type‑archive‑mapping setting, enabling malicious code to be persisted and served to visitors. Because the payload is stored, an attacker who gains access to the plugin’s settings or can trick an administrator into submitting forged data can affect all users who view the impacted pages.

Generated by OpenCVE AI on October 12, 2026 at 10:26 UTC.

Remediation

Vendor Solution

Update the WordPress Custom Query Blocks plugin to the latest available version (at least 5.7.0).


OpenCVE Recommended Actions

  • Upgrade the WordPress Custom Query Blocks plugin to at least version 5.7.0
  • If an upgrade cannot be performed immediately, remove or deactivate the plugin to eliminate the vulnerable code
  • Ensure that only trusted administrators have access to the plugin’s configuration and that no arbitrary scripting input is accepted

Generated by OpenCVE AI on October 12, 2026 at 10:26 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 12 Oct 2026 12:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Mon, 12 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in DLX Plugins Custom Query Blocks post-type-archive-mapping allows Stored XSS.This issue affects Custom Query Blocks: from n/a through 5.6.0.
Title WordPress Custom Query Blocks plugin <= 5.6.0 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-12T11:40:34.371Z

Reserved: 2026-10-09T15:57:23.729Z

Link: CVE-2026-108168

cve-icon Vulnrichment

Updated: 2026-10-12T11:39:17.156Z

cve-icon NVD

Status : Deferred

Published: 2026-10-12T09:16:42.707

Modified: 2026-10-13T13:28:15.717

Link: CVE-2026-108168

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-12T10:30:10Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')