Description
The easy.jobs – AI powered Job Listing, Job Board, Career Page, Recruitment & Hiring Solution plugin for WordPress is vulnerable to Authenticated (Contributor+) Stored Cross-Site Scripting via the 'icon' attribute of the easyjobs/job-list Gutenberg block in all versions up to, and including, 2.8.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-10-28
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross-Site Scripting (XSS)
Action: Immediate Patch
AI Analysis

Impact

The vulnerability allows an authenticated user with contributor-level access to inject malicious scripts into the 'icon' attribute of the easyjobs/job-list Gutenberg block. The object does not sanitize or escape this attribute, so any script placed there is stored and later rendered in the page output. When another visitor accesses that page, the script runs in the visitor's browser, exposing them to data theft, session hijacking, or defacement. The flaw stems from CWE‑79, an unescaped output weakness.

Affected Systems

WordPress sites using the easy.jobs plugin published by wpdevteam. All releases up to and including version 2.8.2 are affected. Both the public plugin page and various editor blocks rely on the insecure 'icon' attribute.

Risk and Exploitability

The CVSS score of 6.4 indicates a moderate severity. EPSS is unavailable, and the vulnerability is not listed in CISA’s KEV catalog, implying that widespread exploitation has not yet been observed. Nonetheless, an attacker who is able to obtain contributor or higher credentials can exploit this stored XSS via the WordPress admin interface, inserting payloads that execute on every user who views the affected job‑list page. The attack vector is limited to authenticated access, but given that contributor accounts are common in content‑heavy environments, the risk surface is broad.

Generated by OpenCVE AI on October 28, 2026 at 08:22 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade easy.jobs to the latest version (≥ 2.8.3) to remove the insecure icon handling logic.
  • If an upgrade is not immediately possible, remove or disable contributor+ access to the 'easyjobs/job-list' block and monitor for attacker activity.
  • Sanitize stored icon attribute values before rendering by applying proper output escaping or stripping script tags, in line with CWE‑79 mitigation best practices.

Generated by OpenCVE AI on October 28, 2026 at 08:22 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The easy.jobs – AI powered Job Listing, Job Board, Career Page, Recruitment & Hiring Solution plugin for WordPress is vulnerable to Authenticated (Contributor+) Stored Cross-Site Scripting via the 'icon' attribute of the easyjobs/job-list Gutenberg block in all versions up to, and including, 2.8.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title easy.jobs <= 2.8.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'icon' Block Attribute
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T06:45:16.742Z

Reserved: 2026-10-09T20:35:23.989Z

Link: CVE-2026-108366

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T07:16:43.963

Modified: 2026-10-28T07:16:43.963

Link: CVE-2026-108366

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T08:30:16Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')