Description
Cross-Site Request Forgery (CSRF) vulnerability in Patreon Patreon WordPress patreon-connect allows Cross Site Request Forgery.This issue affects Patreon WordPress: from n/a through 1.9.17.
Published: 2026-10-12
Score: 8.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross‑Site Request Forgery
Action: Apply Patch
AI Analysis

Impact

A Cross‑Site Request Forgery vulnerability exists in the Patreon WordPress plugin called Patreon Connect. The flaw allows an attacker to craft a request that exploits an authenticated user’s session and forces the user to perform an unintended action on the site, such as changing account settings or authorizing payments. The vulnerability is based on inadequate protection against forged requests, classified as CWE‑352, and could lead to unauthorized changes, data disclosure, or fraudulent activity performed with the privileges of the logged‑in user.

Affected Systems

The issue affects versions of the Patreon Connect WordPress plugin up to and including 1.9.17. The vendor, Patreon, offers the plugin on WordPress via the Patreon WordPress package. No specific minor or patch version information is provided beyond the upper bound of 1.9.17.

Risk and Exploitability

The CVSS score of 8.1 indicates a high impact on confidentiality, integrity, and availability. The exploit probability is not available, but the lack of a warning in the CISA KEV catalog does not diminish the risk if the site is exposed to users who could be tricked into visiting a malicious link. Attackers typically prove the vulnerability by sending an authenticated user to a crafted URL that triggers the disallowed action; therefore, the primary attack vector is a social‑engineering or phishing campaign against site users.

Generated by OpenCVE AI on October 12, 2026 at 18:57 UTC.

Remediation

Vendor Solution

Update the WordPress Patreon WordPress plugin to the latest available version (at least 1.10.0).


OpenCVE Recommended Actions

  • Update the Patreon Connect plugin to version 1.10.0 or later
  • If an immediate update is not possible, restrict or disable any plugin functionality that changes user settings, requiring confirmation or an additional authentication step
  • Implement additional CSRF protection by using a site‑wide security plugin that enforces unique tokens for state‑changing requests
  • Ensure that the WordPress core and all other plugins are kept up to date to reduce the overall attack surface

Generated by OpenCVE AI on October 12, 2026 at 18:57 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 12 Oct 2026 23:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Mon, 12 Oct 2026 17:45:00 +0000

Type Values Removed Values Added
Description Cross-Site Request Forgery (CSRF) vulnerability in Patreon Patreon WordPress patreon-connect allows Cross Site Request Forgery.This issue affects Patreon WordPress: from n/a through 1.9.17.
Title WordPress Patreon WordPress plugin <= 1.9.17 - Cross Site Request Forgery (CSRF) vulnerability
Weaknesses CWE-352
References
Metrics cvssV3_1

{'score': 8.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-12T22:53:59.811Z

Reserved: 2026-10-10T00:19:05.709Z

Link: CVE-2026-108479

cve-icon Vulnrichment

Updated: 2026-10-12T22:52:31.669Z

cve-icon NVD

Status : Deferred

Published: 2026-10-12T18:17:21.187

Modified: 2026-10-13T13:28:15.717

Link: CVE-2026-108479

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-12T19:00:07Z

Weaknesses
  • CWE-352

    Cross-Site Request Forgery (CSRF)