Description
Cross-Site Request Forgery (CSRF) vulnerability in Patreon Patreon WordPress patreon-connect allows Cross Site Request Forgery.This issue affects Patreon WordPress: from n/a through 1.10.0.
Published: 2026-10-12
Score: 7.4 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross Site Request Forgery
Action: Immediate Patch
AI Analysis

Impact

The vulnerability is a classic Cross‑Site Request Forgery flaw that allows an attacker to trigger requests on behalf of an authenticated user. The flaw exists in the Patreon WordPress plugin version 1.10.0 and earlier. A successful exploitation can lead to unauthorized changes or actions performed under the victim’s credentials, potentially resulting in data alteration or loss of control over the WordPress site. The CVSS score of 7.4 indicates that the exploit carries a high severity impact.

Affected Systems

The issue affects the Patreon WordPress plugin from its earliest release through version 1.10.0. All WordPress sites that have installed any of those versions are susceptible; no specific patches are available for older version numbers beyond the stated limit.

Risk and Exploitability

The CVSS metric of 7.4 reflects a significant threat if the attacker can coerce a user into visiting a malicious page while their browser holds an active session cookie. No EPSS data is supplied, and the vulnerability is not listed in the CISA KEV catalog, so the measured likelihood of exploitation is unknown. The attack path typically requires an authenticated user to click or navigate to a crafted link; once triggered, the plugin processes the request without validating the origin, enabling a CSRF attack. Because no additional constraints such as token checks are described, the vulnerability can be exploited by relatively simple social‑engineering or drive‑by scenarios.

Generated by OpenCVE AI on October 12, 2026 at 18:57 UTC.

Remediation

Vendor Solution

Update the WordPress Patreon WordPress plugin to the latest available version (at least 1.11.0).


OpenCVE Recommended Actions

  • Upgrade the Patreon WordPress plugin to version 1.11.0 or later to eliminate the CSRF flaw.
  • Implement or enable anti‑CSRF tokens for all state‑changing requests handled by the plugin, ensuring that each request includes a verifiable token that a legitimate user originates.
  • Audit the plugin’s public endpoints to verify that all actions require proper authentication and that no unauthenticated route can perform privileged operations.

Generated by OpenCVE AI on October 12, 2026 at 18:57 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 12 Oct 2026 23:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Mon, 12 Oct 2026 17:45:00 +0000

Type Values Removed Values Added
Description Cross-Site Request Forgery (CSRF) vulnerability in Patreon Patreon WordPress patreon-connect allows Cross Site Request Forgery.This issue affects Patreon WordPress: from n/a through 1.10.0.
Title WordPress Patreon WordPress plugin <= 1.10.0 - Cross Site Request Forgery (CSRF) vulnerability
Weaknesses CWE-352
References
Metrics cvssV3_1

{'score': 7.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-12T22:53:59.945Z

Reserved: 2026-10-10T00:19:05.709Z

Link: CVE-2026-108481

cve-icon Vulnrichment

Updated: 2026-10-12T22:52:33.223Z

cve-icon NVD

Status : Deferred

Published: 2026-10-12T18:17:21.327

Modified: 2026-10-13T13:28:15.717

Link: CVE-2026-108481

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-12T19:00:07Z

Weaknesses
  • CWE-352

    Cross-Site Request Forgery (CSRF)