Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in LeapWorx Premium Addons for Elementor premium-addons-for-elementor allows Stored XSS.This issue affects Premium Addons for Elementor: from n/a through 4.11.110.
Published: 2026-10-12
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The vulnerability allows an attacker to inject malicious script into content that is later rendered to visitors of a WordPress site. It is a stored XSS flaw originally flagged as CWE‑79, which means that any code supplied by the attacker can persist in the site’s database and run in the browsers of unaware users. An attacker could steal session cookies, deface the site, or redirect users to malicious domains, thereby compromising confidentiality, integrity or availability of the web experience.

Affected Systems

The flaw exists in the LeapWorx Premium Addons for Elementor plugin up to and including version 4.11.110. Any WordPress installation that has this plugin installed and is running 4.11.110 or older is potentially vulnerable; older versions before 4.10 are also included as the vulnerability range is n/a through 4.11.110.

Risk and Exploitability

The CVSS score of 6.5 indicates a medium severity. No EPSS score is provided, and the vulnerability is not listed in the CISA KEV catalog, suggesting it is not presently exploited in the wild. Yet the stored‑XSS nature means that exploitation does not require network‑level access; any user submitting data via the vulnerable plugin can introduce the payload. The attack vector is inferred to be a web‑based input that is stored and later rendered without proper sanitization.

Generated by OpenCVE AI on October 12, 2026 at 19:53 UTC.

Remediation

Vendor Solution

Update the WordPress Premium Addons for Elementor plugin to the latest available version (at least 4.11.111).


OpenCVE Recommended Actions

  • Upgrade the Premium Addons for Elementor plugin to version 4.11.111 or newer
  • Restrict or remove any existing content that may have been created through the vulnerable plugin until the upgrade is complete
  • Scan the database for any stored malicious scripts and remove them before completing the upgrade

Generated by OpenCVE AI on October 12, 2026 at 19:53 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 12 Oct 2026 23:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Mon, 12 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in LeapWorx Premium Addons for Elementor premium-addons-for-elementor allows Stored XSS.This issue affects Premium Addons for Elementor: from n/a through 4.11.110.
Title WordPress Premium Addons for Elementor plugin <= 4.11.110 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-12T22:54:00.236Z

Reserved: 2026-10-10T00:19:05.709Z

Link: CVE-2026-108482

cve-icon Vulnrichment

Updated: 2026-10-12T22:52:37.055Z

cve-icon NVD

Status : Deferred

Published: 2026-10-12T18:17:21.473

Modified: 2026-10-13T13:28:15.717

Link: CVE-2026-108482

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-12T20:00:15Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')