Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS). This issue affects Drupal core versions: from 10.3.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.
Published: 2026-10-30
Score: n/a
EPSS: n/a
KEV: No
Impact: Cross‑Site Scripting
Action: Apply Patch
AI Analysis

Impact

Improper neutralization of input during web page generation in Drupal core allows attackers to inject malicious scripts that execute in the context of the victim’s browser. Stored or reflected XSS could enable session hijacking, credential theft, or phishing attacks against site users. The affected code in Drupal core lacks appropriate sanitization on user‑supplied data rendered in page output.

Affected Systems

This vulnerability is present in Drupal core from versions 10.3.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, and from 12.0.0‑alpha1 to 12.0.0‑beta2. Any website running one of these core releases without a later patch is susceptible. The issue affects the Drupal:Drupal core product line.

Risk and Exploitability

The CVSS score is not provided, and EPSS is unavailable; the vulnerability is not listed in CISA KEV. Despite this, the potential for significant impact remains, as XSS can be triggered through a wide array of user input paths such as comments, form fields, or URL parameters. An attacker can exploit the flaw without authentication, or with minimal privileges, by crafting a malicious payload that is rendered on a page. The combined risk is moderate to high for unpatched installations, warranting immediate remediation.

Generated by OpenCVE AI on October 30, 2026 at 04:30 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade to a patched Drupal core release that is not affected by the XSS flaw (e.g., 10.6.20 or newer, 11.3.20 or newer, 11.4.11 or newer, 12.0.0‑beta3 or newer).
  • Verify that no legacy modules or custom code reintroduces unsanitized output; remove or hard‑code protections for any that do.
  • Apply a site‑wide Content Security Policy that disallows inline scripts and limits external script sources to trusted origins.

Generated by OpenCVE AI on October 30, 2026 at 04:30 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

References
History

Fri, 30 Oct 2026 05:30:00 +0000

Type Values Removed Values Added
First Time appeared Drupal
Drupal drupal Core
Vendors & Products Drupal
Drupal drupal Core

Fri, 30 Oct 2026 03:30:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS). This issue affects Drupal core versions: from 10.3.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.
Title Drupal core - Moderately critical - Cross-site scripting - SA-CORE-2026-016
Weaknesses CWE-79
References

Subscriptions

Drupal Drupal Core
cve-icon MITRE

Status: PUBLISHED

Assigner: drupal

Published:

Updated: 2026-10-30T03:09:51.346Z

Reserved: 2026-10-10T07:33:14.299Z

Link: CVE-2026-108514

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-30T04:18:05.750

Modified: 2026-10-30T04:18:05.750

Link: CVE-2026-108514

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T05:15:08Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')