Description
The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'bbp_reply_content' parameter in all versions up to, and including, 7.9.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that an administrator has enabled Viewport Images (VPI) and configured a VPI filename that matches an image the attacker can embed in user-generated content — such as a bbPress topic where Subscriber-level Participants are permitted to post replies containing raw img tags.
Published: 2026-10-29
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS) in LiteSpeed Cache plugin for WordPress
Action: Immediate Patch
AI Analysis

Impact

The LiteSpeed Cache plugin for WordPress contains a stored cross‑site scripting flaw that accepts unsanitized content from the bbp_reply_content field, allowing an attacker who can submit bbPress replies to inject arbitrary script tags that will be re‑serialized by the Viewport Images (VPI) subsystem. When an authenticated user with subscriber‑level or higher access posts a reply containing a raw img tag that references a VPI‑configured filename, the malicious payload is saved to the database and subsequently delivered to any website visitor who views the reply. The injected scripts run in the context of the site, potentially compromising user credentials, session data, or defacing pages, thereby creating a significant threat to confidentiality and integrity on sites using this plugin.

Affected Systems

The vulnerability affects the LiteSpeed Cache plugin for WordPress from all versions up to and including 7.9.1, a product maintained by LiteSpeed Technologies. Users who have installed versions 7.9.1 or older are exposed, regardless of WordPress core version, and any site that has enabled the library’s Viewport Images feature for subscriber‑level content.

Risk and Exploitability

The flaw carries a CVSS score of 6.4, indicating medium severity, and is not listed in CISA’s KEV catalog. No EPSS value is provided, but the requirement for authenticated access and a specific VPI image configuration suggests a moderate exploitation likelihood in environments where many subscribers exist or where VPI is enabled. Attackers can leverage this vector to execute scripts on the browsers of any user who views the infected reply, so the risk is heightened for sites with active bbPress forums or similar user‑generated content.

Generated by OpenCVE AI on October 29, 2026 at 10:22 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade LiteSpeed Cache to the latest release (7.9.2 or later) which includes input sanitization changes that eliminate the stored XSS vulnerability.
  • If an upgrade cannot be performed immediately, disable the Viewport Images feature or restrict it so that only trusted administrators can enqueue image filenames that match user‑supplied image data, effectively removing the injection path for subscriber accounts.
  • Reconfigure WordPress user roles and bbPress reply settings so that subscribers or lower‑privileged users cannot post raw img tags, and enforce content sanitization filters such as wp_kses_post on bbPress reply content.

Generated by OpenCVE AI on October 29, 2026 at 10:22 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 29 Oct 2026 09:45:00 +0000

Type Values Removed Values Added
Description The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'bbp_reply_content' parameter in all versions up to, and including, 7.9.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that an administrator has enabled Viewport Images (VPI) and configured a VPI filename that matches an image the attacker can embed in user-generated content — such as a bbPress topic where Subscriber-level Participants are permitted to post replies containing raw img tags.
Title LiteSpeed Cache <= 7.9.1 - Authenticated (Subscriber+) Stored Cross-Site Scripting via VPI Image Attribute Re-Serialization
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-29T10:45:41.071Z

Reserved: 2026-10-12T13:39:03.783Z

Link: CVE-2026-109215

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-29T10:17:02.727

Modified: 2026-10-29T10:17:02.727

Link: CVE-2026-109215

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-29T10:30:11Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')