Description
The Customer Email Verification for WooCommerce plugin for WordPress is vulnerable to Authentication Bypass via a Predictable Email-Verification Token in all versions up to, and including, 2.8.2. This is due to the `authenticate_user_by_email_link()` function — hooked on the `wp` action and triggered by the `cusomer_email_verify` GET parameter — lacking any capability check or nonce verification, while the `secret_code` it validates is generated as `md5(email . time())` and the `verify_otp_nonce` required to trigger token issuance via the `wp_ajax_nopriv_resend_otp` handler is emitted to every front-end visitor through `wp_localize_script`. This makes it possible for unauthenticated attackers to log in as a newly created, verified WooCommerce customer bound to an arbitrary email address — or to flip an existing account's `customer_email_verified` meta to verified — fully bypassing the plugin's core email-verification control. Exploitation requires the `cev_user_log` table to contain a `password` column, which is absent from the fresh-install schema shipped in version 2.8.2 but is present on sites upgraded from an older version where that column was defined.
Published: 2026-10-28
Score: 4.8 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Authentication Bypass via Predictable Email-Verification Token
Action: Immediate Patch
AI Analysis

Impact

The Customer Email Verification for WooCommerce plugin is vulnerable because its email‑verification endpoint accepts a GET parameter without proper authorization checks or nonce verification, and the secret code it validates is generated from an easily predictable md5 hash of the user’s email and the current time. This flaw allows any unauthenticated visitor to craft a verification link that, when processed, marks a newly created customer or flips an existing account’s customer_email_verified flag, effectively bypassing the plugin’s core email‑verification control and enabling an attacker to impersonate the customer. The impact includes unauthorized access to personal data, order history, and purchasing capabilities, compromising confidentiality, integrity, and e‑commerce functionality.

Affected Systems

WordPress sites that have installed the zorem Customer Email Verification for WooCommerce plugin version 2.8.2 or earlier are affected. The vulnerability is exploitable only on installations that upgraded from earlier releases and therefore retain the obsolete cev_user_log table with a password column; fresh installs of 2.8.2 do not expose this column, limiting the attack surface to legacy database schemas that still contain the password field.

Risk and Exploitability

The CVSS score of 4.8 indicates a moderate severity. No EPSS data is available, and the vulnerability is not listed in the CISA KEV catalog, suggesting limited known exploitation. Attackers can reach the vulnerable endpoint from the public internet by sending a crafted request to the cusomer_email_verify query parameter. Successful exploitation would allow an unauthenticated attacker to impersonate a customer on affected WordPress sites, potentially accessing sensitive personal information and performing fraudulent purchases.

Generated by OpenCVE AI on October 28, 2026 at 06:50 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Apply the official patch by upgrading Customer Email Verification for WooCommerce to version 2.8.3 or later as released by the vendor.
  • If an upgrade is not immediately possible, disable or remove the cusomer_email_verify query parameter handling in the plugin or implement a capability check to restrict access to authenticated administrators only.
  • Remove or truncate the obsolete cev_user_log table or delete the password column if it remains on upgraded sites to eliminate the exploit surface.

Generated by OpenCVE AI on October 28, 2026 at 06:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
Description The Customer Email Verification for WooCommerce plugin for WordPress is vulnerable to Authentication Bypass via a Predictable Email-Verification Token in all versions up to, and including, 2.8.2. This is due to the `authenticate_user_by_email_link()` function — hooked on the `wp` action and triggered by the `cusomer_email_verify` GET parameter — lacking any capability check or nonce verification, while the `secret_code` it validates is generated as `md5(email . time())` and the `verify_otp_nonce` required to trigger token issuance via the `wp_ajax_nopriv_resend_otp` handler is emitted to every front-end visitor through `wp_localize_script`. This makes it possible for unauthenticated attackers to log in as a newly created, verified WooCommerce customer bound to an arbitrary email address — or to flip an existing account's `customer_email_verified` meta to verified — fully bypassing the plugin's core email-verification control. Exploitation requires the `cev_user_log` table to contain a `password` column, which is absent from the fresh-install schema shipped in version 2.8.2 but is present on sites upgraded from an older version where that column was defined.
Title Customer Email Verification for WooCommerce <= 2.8.2 - Unauthenticated Authentication Bypass via Predictable Email-Verification Token to 'cusomer_email_verify' Parameter
Weaknesses CWE-287
References
Metrics cvssV3_1

{'score': 4.8, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T05:33:31.213Z

Reserved: 2026-10-12T14:04:30.464Z

Link: CVE-2026-109236

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-28T06:16:33.237

Modified: 2026-10-28T13:46:33.207

Link: CVE-2026-109236

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T07:00:11Z

Weaknesses