Description
The Document Embedder – let visitors read files without downloading plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'content (post_content containing block JSON documentSource.doc)' parameter in all versions up to, and including, 2.4.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The payload is triggered specifically when the victim clicks the embedded document's Download button, which causes the de_track_download AJAX fallback path to programmatically create an anchor with the attacker-controlled href and call .click() — a condition reached because supplying docId=0 causes can_read_document() to return false, bypassing the normal download flow.
Published: 2026-10-28
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Cross‑Site Scripting (DOM‑based)
Action: Patch
AI Analysis

Impact

The vulnerability exists in the Document Embedder – let visitors read files without downloading plugin for WordPress and is a stored, DOM‑based cross‑site scripting flaw. It is caused by inadequate sanitization and escaping of the block JSON attribute documentSource.doc that is stored in post_content. An authenticated contributor or higher can inject malicious JavaScript payloads that are executed when a visitor clicks the embedded document’s Download button, which triggers an AJAX path that creates a malicious anchor and programmatically clicks it.

Affected Systems

All WordPress installations that use the Document Embedder – let visitors read files without downloading plugin with a version of 2.4.0 or older are vulnerable. The plugin is provided by bplugins.

Risk and Exploitability

The CVSS score of 6.4 indicates moderate severity, and the EPSS score is not available. The vulnerability is not listed in the CISA KEV catalog. Exploitation requires the attacker to possess contributor‑level permissions or higher within the WordPress site to insert the malicious block, and a victim must actively click the Download button for the payload to execute. The combination of privilege requirement and user interaction mitigates the overall risk compared to a purely remote code execution flaw, yet the impact on confidentiality, integrity, and availability of the affected site remains significant.

Generated by OpenCVE AI on October 28, 2026 at 08:21 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Document Embedder plugin to a version newer than 2.4.0, such as 2.4.1 or later.
  • Identify and remove any posts or content blocks that contain the injected documentSource.doc JSON payloads.
  • Limit contributor and higher role permissions or enforce stricter content moderation to prevent unauthorized script injection.

Generated by OpenCVE AI on October 28, 2026 at 08:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The Document Embedder – let visitors read files without downloading plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'content (post_content containing block JSON documentSource.doc)' parameter in all versions up to, and including, 2.4.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The payload is triggered specifically when the victim clicks the embedded document's Download button, which causes the de_track_download AJAX fallback path to programmatically create an anchor with the attacker-controlled href and call .click() — a condition reached because supplying docId=0 causes can_read_document() to return false, bypassing the normal download flow.
Title Document Embedder <= 2.4.0 - Authenticated (Contributor+) Stored DOM-Based Cross-Site Scripting via 'documentSource.doc' Block Attribute
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T06:45:19.156Z

Reserved: 2026-10-12T14:22:26.994Z

Link: CVE-2026-109370

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T07:16:44.270

Modified: 2026-10-28T07:16:44.270

Link: CVE-2026-109370

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T08:30:16Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')