Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Elementor Elementor Website Builder elementor allows Reflected XSS.This issue affects Elementor Website Builder: from n/a through 4.3.5.
Published: 2026-11-06
Score: 7.1 High
EPSS: n/a
KEV: No
Impact: Cross-site scripting allowing arbitrary client‑side code execution
Action: Patch
AI Analysis

Impact

The Elementor plugin includes an input handling flaw that fails to neutralize user data before injecting it into generated HTML, a classic Reflected XSS vulnerability (CWE‑79). An attacker could supply a specially crafted string that is then reflected in the page, enabling the execution of malicious JavaScript in the victim’s browser. The consequences include theft of credentials, session hijacking, defacement or delivery of additional malware, all without compromising the server itself.

Affected Systems

Any site running Elementor Website Builder version 4.3.5 or earlier is susceptible. The vulnerability is present across all affected releases of the plugin for WordPress, regardless of other theme or plugin configurations.

Risk and Exploitability

The CVSS score of 7.1 classifies it as a high‑severity flaw. EPSS data is currently unavailable, and the issue has not been listed in the CISA KEV catalog, suggesting that a widespread, detected exploitation campaign is not yet reported. The likely attack vector is reflected XSS, where an adversary supplies malicious payloads via URLs, form input, or other unfiltered data paths that the plugin renders in the browser. Successful exploitation would require a victim to visit a crafted page or click a malicious link; authentication to the site is not strictly required for the attack to trigger.

Generated by OpenCVE AI on November 6, 2026 at 13:21 UTC.

Remediation

Vendor Solution

Update the WordPress Elementor Website Builder plugin to the latest available version (at least 4.3.6).


OpenCVE Recommended Actions

  • Upgrade Elementor Website Builder to version 4.3.6 or later
  • Re‑install the updated plugin to ensure all component files are correctly replaced
  • Implement a Content Security Policy that blocks inline scripts and disallows eval to mitigate XSS until the vulnerability is fully patched

Generated by OpenCVE AI on November 6, 2026 at 13:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 06 Nov 2026 12:30:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Elementor Elementor Website Builder elementor allows Reflected XSS.This issue affects Elementor Website Builder: from n/a through 4.3.5.
Title WordPress Elementor Website Builder plugin <= 4.3.5 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-06T12:09:26.933Z

Reserved: 2026-10-13T09:24:58.244Z

Link: CVE-2026-109884

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-06T13:17:23.300

Modified: 2026-11-06T13:17:23.417

Link: CVE-2026-109884

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-06T13:30:05Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')