Description
Missing Authorization vulnerability in Melapress Melapress Role Editor melapress-role-editor allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Melapress Role Editor: from n/a through 1.3.0.
Published: 2026-11-08
Score: 7.1 High
EPSS: n/a
KEV: No
Impact: Privilege Escalation
Action: Immediate Patch
AI Analysis

Impact

The Melapress Role Editor plugin for WordPress contains a missing authorization flaw (CWE-862) that allows an attacker to modify user roles without proper access control. This broken access control lets an unauthorized or poorly privileged user gain elevated privileges, potentially enabling them to assume administrative rights or perform other high‑impact actions. The vulnerability carries a CVSS score of 7.1, indicating high severity.

Affected Systems

WordPress sites that have the Melapress Role Editor plugin installed at version 1.3.0 or older are affected. The issue impacts all versions from the earliest released up to and including 1.3.0 and appears to affect the default configuration of the plugin. No other product or version information is provided.

Risk and Exploitability

The CVSS score of 7.1 signals a serious risk, but the EPSS score is not available, so the current probability of exploitation is unknown. The likely attack vector is a remote web request to the plugin’s role‑editing interface that does not enforce proper role checks, which is inferred based on the plugin’s exposed functionality. The vulnerability is not listed in the CISA KEV catalog, suggesting that no large‑scale exploitation campaigns are known at this time. Nonetheless, an attacker who can authenticate to the WordPress site could leverage this flaw to elevate privileges and compromise site integrity.

Generated by OpenCVE AI on November 8, 2026 at 17:52 UTC.

Remediation

Vendor Solution

Update the WordPress Melapress Role Editor plugin to the latest available version (at least 1.4.0).


OpenCVE Recommended Actions

  • Update the Melapress Role Editor plugin to version 1.4.0 or later, which contains the official fix.
  • If an update is not possible, uninstall or deactivate the plugin to remove the broken access control surface.
  • Verify that the WordPress installation enforces strict role checks so that only users with administrator rights can modify roles, and confirm that the plugin’s settings are configured to restrict role edits to administrators only. This addresses the missing authorization (CWE-862).
  • Monitor user accounts and role changes for indicators of unauthorized privilege escalation.

Generated by OpenCVE AI on November 8, 2026 at 17:52 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 08 Nov 2026 16:15:00 +0000

Type Values Removed Values Added
Description Missing Authorization vulnerability in Melapress Melapress Role Editor melapress-role-editor allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Melapress Role Editor: from n/a through 1.3.0.
Title WordPress Melapress Role Editor plugin <= 1.3.0 - Broken Access Control vulnerability
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-08T18:55:19.168Z

Reserved: 2026-10-13T09:24:58.244Z

Link: CVE-2026-109899

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-08T16:16:36.603

Modified: 2026-11-08T16:16:36.733

Link: CVE-2026-109899

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-08T18:00:16Z

Weaknesses