Description
Incorrect Privilege Assignment vulnerability in Melapress Melapress Role Editor melapress-role-editor allows Privilege Escalation.This issue affects Melapress Role Editor: from n/a through 1.3.0.
Published: 2026-11-08
Score: 9.6 Critical
EPSS: n/a
KEV: No
Impact: Privilege Escalation
Action: Immediate Patch
AI Analysis

Impact

The vulnerability is an Incorrect Privilege Assignment flaw that allows an attacker to elevate their privileges through the Melapress Role Editor WordPress plugin. By exploiting the flaw, an attacker can assign themselves a higher role or grant elevated rights to other users, potentially gaining full administrative control over the WordPress site. This elevates the risk of data tampering, unauthorized access, or sabotage of site functions, and the weakness is categorized as a role‑based access control breach (CWE‑266).

Affected Systems

Melapress Role Editor plugin for WordPress, version 1.3.0 and earlier. The vulnerability applies across all revisions from the earliest release up to and including 1.3.0, with no identified fixed versions prior to that release.

Risk and Exploitability

The CVSS score of 9.6 places this flaw in the "Critical" range, underscoring its severe impact. The associated EPSS score is not available, leaving the exploitation probability uncertain, and the flaw is not listed in the CISA KEV catalog. Based on the description, it is inferred that the likely attack vector is via the plugin’s role editing interface or API calls, allowing a user with sufficient access to the site to trigger the privilege escalation. The absence of an EPSS value means defenders lack a precise likelihood metric, but the high CVSS and lack of mitigations recommend treating this as an urgency‑high risk scenario.

Generated by OpenCVE AI on November 8, 2026 at 17:22 UTC.

Remediation

Vendor Solution

Update the WordPress Melapress Role Editor plugin to the latest available version (at least 1.4.0).


OpenCVE Recommended Actions

  • Update the Melapress Role Editor plugin to version 1.4.0 or later as the vendor’s official fix.
  • Disable the Melapress Role Editor plugin until the update can be applied to block the vulnerable functionality.
  • Review WordPress user accounts and trim any unnecessary administrator or editor roles, ensuring the principle of least privilege is enforced.

Generated by OpenCVE AI on November 8, 2026 at 17:22 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 08 Nov 2026 16:15:00 +0000

Type Values Removed Values Added
Description Incorrect Privilege Assignment vulnerability in Melapress Melapress Role Editor melapress-role-editor allows Privilege Escalation.This issue affects Melapress Role Editor: from n/a through 1.3.0.
Title WordPress Melapress Role Editor plugin <= 1.3.0 - Privilege Escalation vulnerability
Weaknesses CWE-266
References
Metrics cvssV3_1

{'score': 9.6, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-08T18:55:18.891Z

Reserved: 2026-10-13T09:24:58.244Z

Link: CVE-2026-109900

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-08T16:16:36.773

Modified: 2026-11-08T16:16:36.890

Link: CVE-2026-109900

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-08T17:30:15Z

Weaknesses
  • CWE-266

    Incorrect Privilege Assignment