Description
The Cozy Blocks – Website Builder for WordPress Block Editor | Gutenberg Blocks, Patterns & Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content (block attribute icon.view / icon.layout / icon.gap)' parameter in all versions up to, and including, 2.2.27 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Although wp_kses_post is applied on save, it does not neutralize a quote-only attribute-breakout payload containing no '<' character, leaving the block comment and its decoded JSON attributes intact and exploitable at render time.
Published: 2026-10-28
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Authenticated Stored Cross‑Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The Cozy Blocks plugin allows contributors and higher‑privilege users to insert arbitrary scripts through the icon view attribute in block definitions. Because the plugin fails to fully escape quotes and other attribute delimiters, an attacker can place a payload that is stored in the block’s JSON metadata and later executed whenever any site visitor loads the affected page. This creates a cross‑site scripting condition that can be leveraged to steal session cookies, deface content, or perform further actions in the context of the browsing user.

Affected Systems

WordPress sites running Cozy Blocks version 2.2.27 or any earlier release are affected. The vulnerability exists on all builds of the plugin where the 'icon.view', 'icon.layout', or 'icon.gap' block attributes are defined, regardless of active theme or other plugins. Sites that grant contributor or higher rights to users can be used to supply the malicious block content.

Risk and Exploitability

The CVSS score of 6.4 indicates moderate severity, and the EPSS metric is not available, so the likelihood of widespread exploitation is uncertain. The vulnerability is not listed in the KEV catalog, meaning no publicly known active exploits have been reported. Attackers need authenticated contributor or higher access and must embed the script in a block; once stored, the code runs for every visitor to the page that renders the block. As the stored payload is not neutralized by wp_kses_post, the impact can be maintained across future widget edits and updates until patched.

Generated by OpenCVE AI on October 28, 2026 at 08:20 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update Cozy Blocks to version 2.2.28 or later, which removes the insecure attribute handling.
  • For existing content, purge or sanitize the 'icon.view' attribute in all affected blocks and regenerate page renders.
  • Restrict contributor and higher level roles from editing or adding blocks, or temporarily disable the block type until a patch is applied.

Generated by OpenCVE AI on October 28, 2026 at 08:20 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The Cozy Blocks – Website Builder for WordPress Block Editor | Gutenberg Blocks, Patterns & Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content (block attribute icon.view / icon.layout / icon.gap)' parameter in all versions up to, and including, 2.2.27 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Although wp_kses_post is applied on save, it does not neutralize a quote-only attribute-breakout payload containing no '<' character, leaving the block comment and its decoded JSON attributes intact and exploitable at render time.
Title Cozy Blocks <= 2.2.27 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'icon.view' Block Attribute
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T06:45:22.335Z

Reserved: 2026-10-13T11:51:43.905Z

Link: CVE-2026-109975

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T07:16:45.163

Modified: 2026-10-28T07:16:45.163

Link: CVE-2026-109975

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T08:30:16Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')