Description
The Cozy Blocks – Website Builder for WordPress Block Editor | Gutenberg Blocks, Patterns & Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'productRating.iconColor' parameter in all versions up to, and including, 2.2.27 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerable code path is only reached when the productRating option is enabled and the associated WooCommerce product has a non-zero rating.
Published: 2026-10-28
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch Now
AI Analysis

Impact

An authenticated user with contributor or higher access can inject arbitrary JavaScript into WordPress pages through the Cozy Blocks productRating iconColor attribute. The injected payload is stored and rendered whenever a page containing the productRating block is viewed, creating a stored cross‑site scripting flaw that executes in the browsers of all visitors to the affected page.

Affected Systems

The Cozy Blocks – Website Builder & Business Growth Toolkit by Cozy Themes, a Gutenberg‑based WordPress plugin, is affected in every release up to version 2.2.27. No other product or version ranges were identified in the available data.

Risk and Exploitability

The CVSS score of 6.4 indicates moderate severity, and the vulnerability is only exploitable by an authenticated user with contributor privileges or higher. External IP‑based attacks are not possible, and the EPSS score is not available. While the issue has not been listed in the CISA KEV catalog, an attacker who obtains the required permissions can readily deploy the stored payload and compromise any user who views the affected page.

Generated by OpenCVE AI on October 28, 2026 at 08:52 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Apply the latest Cozy Blocks release newer than 2.2.27 which removes the unescaped iconColor attribute
  • If the productRating feature is not required, disable it or delete any blocks that contain the vulnerable attribute
  • Audit existing pages for injected scripts, clean them from the database, and verify that output is properly escaped in the finished content

Generated by OpenCVE AI on October 28, 2026 at 08:52 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The Cozy Blocks – Website Builder for WordPress Block Editor | Gutenberg Blocks, Patterns & Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'productRating.iconColor' parameter in all versions up to, and including, 2.2.27 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerable code path is only reached when the productRating option is enabled and the associated WooCommerce product has a non-zero rating.
Title Cozy Blocks <= 2.2.27 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'productRating.iconColor' Block Attribute
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T06:45:09.376Z

Reserved: 2026-10-13T11:56:28.154Z

Link: CVE-2026-109978

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T07:16:45.313

Modified: 2026-10-28T07:16:45.313

Link: CVE-2026-109978

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T09:00:10Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')