Description
The FV Flowplayer Video Player plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 7.5.55.7212 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the 'Parse Vimeo and YouTube links' option to be enabled and a site administrator to approve the comment containing the malicious shortcode; execution is then triggered for any visitor who interacts with the video player on that page.
Published: 2026-10-30
Score: 5.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Apply Patch
AI Analysis

Impact

The FV Flowplayer Video Player plugin for WordPress is vulnerable to stored Cross‑Site Scripting by abusing the 'comment' parameter, which is insufficiently sanitized and unescaped. Unauthenticated attackers can inject a malicious shortcode containing arbitrary JavaScript. When a site administrator approves the comment, the script is executed in the browser of any visitor who interacts with the video player on that page.

Affected Systems

The vulnerability affects the foliovision FV Flowplayer Video Player plugin for WordPress, all versions up to and including 7.5.55.7212.

Risk and Exploitability

The CVSS score of 5.4 indicates moderate severity. The EPSS score is not available, and the vulnerability is not listed in the CISA KEV catalog. An attacker can exploit this flaw without authentication, but the exploitation requires the factory setting 'Parse Vimeo and YouTube links' to be enabled and a site administrator to manually approve the malicious comment. These conditions yield a limited yet realistic attack surface for a site that allows comments and has the option enabled.

Generated by OpenCVE AI on October 30, 2026 at 18:21 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the FV Flowplayer Video Player plugin to the latest available version that contains the fix for this vulnerability.
  • Disable the 'Parse Vimeo and YouTube links' option until the plugin is updated to prevent the execution of injected shortcodes.
  • Review and remove any comments that contain the malicious '@ad' shortcode or other injected code.

Generated by OpenCVE AI on October 30, 2026 at 18:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 19:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 30 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Description The FV Flowplayer Video Player plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 7.5.55.7212 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the 'Parse Vimeo and YouTube links' option to be enabled and a site administrator to approve the comment containing the malicious shortcode; execution is then triggered for any visitor who interacts with the video player on that page.
Title FV Flowplayer Video Player <= 7.5.55.7212 - Unauthenticated Stored Cross-Site Scripting via 'ad' Shortcode Attribute in Comments
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 5.4, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-30T18:08:57.382Z

Reserved: 2026-10-13T12:21:36.366Z

Link: CVE-2026-109984

cve-icon Vulnrichment

Updated: 2026-10-30T18:01:06.808Z

cve-icon NVD

Status : Deferred

Published: 2026-10-30T18:17:19.527

Modified: 2026-10-30T19:18:08.190

Link: CVE-2026-109984

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T18:30:16Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')