Description
The Product Addons for Woocommerce – Product Options with Custom Fields plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'fields[section][fields][row][col][type]' parameter in all versions up to, and including, 3.1.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with shop manager-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-10-28
Score: 4.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross-Site Scripting
Action: Update Plugin
AI Analysis

Impact

This vulnerability allows attackers who have shop manager or higher privileges in WordPress to inject malicious scripts into pages via the type field in the Product Addons plugin. The injection is stored, meaning the code persists across sessions and is executed for any user who views the affected page, leading to execution of arbitrary client‑side code. The weakness is a classic stored XSS flaw (CWE‑79).

Affected Systems

WordPress users running the Product Addons for WooCommerce – Product Options with Custom Fields plugin, version 3.1.8 or older. No specific product variants or sub‑versions are listed beyond the major release. All users who can manage shop content are potentially affected.

Risk and Exploitability

The CVSS score of 4.4 indicates a moderate severity; the vulnerability requires authenticated access but grants no direct system compromise. Because the exploit depends on legitimate shop‑manager credentials, it is less likely to be widely automated, and no EPSS or KEV data suggests high exploitation probability. The attacker’s goal is to subvert end‑user browsers with XSS payloads, which could result in session hijacking, defacement, or theft of customer data. It is recommended to treat this safely given the confirmed injection surface and the potential damage to visitor trust.

Generated by OpenCVE AI on October 28, 2026 at 08:22 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Product Addons for WooCommerce to the latest version, removing the vulnerable handler for the type field
  • Restrict shop‑manager level user roles to only necessary permissions and audit role assignments regularly
  • Deploy a web application firewall or // CSP headers to block reflective or injected scripts on output pages

Generated by OpenCVE AI on October 28, 2026 at 08:22 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The Product Addons for Woocommerce – Product Options with Custom Fields plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'fields[section][fields][row][col][type]' parameter in all versions up to, and including, 3.1.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with shop manager-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title Product Addons for Woocommerce <= 3.1.8 - Authenticated (Shop Manager+) Stored Cross-Site Scripting via 'type' Field Parameter
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 4.4, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T06:45:17.956Z

Reserved: 2026-10-13T12:32:15.469Z

Link: CVE-2026-109988

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T07:16:45.747

Modified: 2026-10-28T07:16:45.747

Link: CVE-2026-109988

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T08:30:16Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')