Description
The Eventin – Events Calendar, Tickets, Registration, Booking & WooCommerce plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.1.29 via the 'id' parameter. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract the email address and phone number of any WordPress user, including administrators, by supplying their user id in a query-string parameter while placing the authenticated user's own id in the URL path.
Published: 2026-11-06
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Sensitive Information Exposure of User Contact Data
Action: Patch
AI Analysis

Impact

The Eventin plugin for WordPress is vulnerable in versions up to 4.1.29 to a sensitive information exposure flaw. The issue allows an authenticated attacker with subscriber-level or higher access to retrieve the email address and phone number of any WordPress user, including administrators, by supplying that user's ID in an 'id' query‑string parameter. Attackers need only to be logged in and provide a valid user ID; the plugin fails to enforce proper authorization checks before exposing these fields.

Affected Systems

WordPress sites using the Eventin Events Calendar, Tickets, Registration, Booking & WooCommerce plugin, any version 4.1.29 or earlier. No specific hardware or WordPress version is singled out, so all deployments of the affected plugin versions are at risk.

Risk and Exploitability

The vulnerability carries a CVSS score of 6.5, indicating a moderate severity that could compromise confidentiality of user contact information. Because the attacker must be authenticated, the threat is restricted to users already logged in; however, subscriber-level users are widely present on many sites. The EPSS score is unavailable, and the flaw is not currently listed in CISA's KEV catalog, suggesting no widespread active exploitation yet. Nevertheless, the exposure of personal data can lead to privacy violations and regulatory non‑compliance, warranting prompt remediation.

Generated by OpenCVE AI on November 6, 2026 at 10:22 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Eventin plugin to any version newer than 4.1.29
  • Verify role‑based access controls so that subscriber and lower roles cannot request data about other users
  • Place monitoring on API endpoints that accept user‑id parameters to detect abnormal requests that may indicate abuse

Generated by OpenCVE AI on November 6, 2026 at 10:22 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 06 Nov 2026 09:45:00 +0000

Type Values Removed Values Added
Description The Eventin – Events Calendar, Tickets, Registration, Booking & WooCommerce plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.1.29 via the 'id' parameter. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract the email address and phone number of any WordPress user, including administrators, by supplying their user id in a query-string parameter while placing the authenticated user's own id in the URL path.
Title Eventin <= 4.1.29 - Missing Authorization to Authenticated (Subscriber+) Sensitive Information Exposure via 'id' Parameter
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-06T09:38:13.839Z

Reserved: 2026-10-13T13:25:10.070Z

Link: CVE-2026-109994

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-06T10:16:35.767

Modified: 2026-11-06T10:16:35.907

Link: CVE-2026-109994

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-06T10:30:18Z

Weaknesses