Description
The Advanced Views – Display Framework for Gutenberg & Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 3.9.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is exploitable even against pending or unapproved comments, as the plugin's get_comment() lookup applies no approval-status filter, meaning a payload executes for any visitor loading an avf-layout block bound to the attacker's comment ID before the comment is ever reviewed.
Published: 2026-10-27
Score: 7.2 High
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Patch Now
AI Analysis

Impact

The Advanced Views – Display Framework plugin contains a flaw that fails to sanitize and escape user supplied comment content, allowing unauthenticated attackers to store malicious scripts that are executed when visitors load a page containing the comment. This stored XSS can lead to session hijacking, defacement, or theft of client‑side data and is classified as CWE‑79.

Affected Systems

Vendors: wplakeorg; Product: Advanced Views – Display Framework – Gutenberg/Elementor/Shortcode. Affected versions are all releases up to and including 3.9.6; the issue is reported to be fixed in later releases such as 3.9.7.

Risk and Exploitability

The CVSS score of 7.2 indicates a moderate‑to‑high severity, while the EPSS score is not available and the vulnerability is not listed in CISA KEV. The likely attack vector is any unauthenticated web user who can insert a crafted comment, as the plugin retrieves comment data without applying an approval filter, meaning the payload runs for any visitor before the comment is moderated. Given the potential impact on user browsers and the lack of requirement for privileged access, the risk is high if the plugin is in use without a patch.

Generated by OpenCVE AI on October 27, 2026 at 12:21 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Advanced Views to version 3.9.7 or later to apply the vendor fix.
  • Configure the plugin to display comment content only for approved comments or enable comment moderation before comments are available to the avf‑layout blocks.
  • If immediate updating is not possible, restrict or remove the comment rendering feature for unmoderated comments by editing the layout template or applying a custom filter that encodes comment output.

Generated by OpenCVE AI on October 27, 2026 at 12:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 27 Oct 2026 11:45:00 +0000

Type Values Removed Values Added
Description The Advanced Views – Display Framework for Gutenberg & Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 3.9.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is exploitable even against pending or unapproved comments, as the plugin's get_comment() lookup applies no approval-status filter, meaning a payload executes for any visitor loading an avf-layout block bound to the attacker's comment ID before the comment is ever reviewed.
Title Advanced Views <= 3.9.6 - Unauthenticated Stored Cross-Site Scripting via Comment Content
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.2, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-27T11:32:03.735Z

Reserved: 2026-10-13T13:34:31.475Z

Link: CVE-2026-109995

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-27T12:17:04.543

Modified: 2026-10-27T14:52:13.410

Link: CVE-2026-109995

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-27T12:30:02Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')