Description
The Page Builder by SiteOrigin WordPress plugin before 2.38.0 does not sanitize or escape a widget property before storing it and outputting it in the page builder interface, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks against higher-privileged users who open the affected post in the editor.
Published: 2026-10-28
Score: n/a
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch
AI Analysis

Impact

The Page Builder by SiteOrigin plugin for WordPress versions prior to 2.38.0 does not properly sanitize a widget property before saving it to the database and later rendering it in the page builder interface. This flaw allows a user with the Contributor role or higher to inject arbitrary JavaScript, which is stored and re‑displayed whenever the content is edited. When an administrator or editor opens the affected post, the malicious script runs in that user's browser, potentially exposing session cookies, extracting credentials, or altering page content.

Affected Systems

Any WordPress site that has the Page Builder by SiteOrigin plugin installed with a version older than 2.38.0 and that allows users with Contributor or greater permissions to edit content using the plugin.

Risk and Exploitability

The flaw is a classic stored cross‑site scripting vulnerability (CWE‑79). It can be exploited locally by editing a widget that accepts widget data; no external network traffic is needed beyond normal content editing. The EPSS score is not available and the vulnerability is not listed in the CISA KEV catalog. The impact is medium‑high for sites that permit contributors to edit, because the injected script will execute in the browser of any subsequent editor or administrator who opens the content in the page builder interface.

Generated by OpenCVE AI on October 28, 2026 at 07:52 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Page Builder by SiteOrigin plugin to version 2.38.0 or later.
  • If an upgrade cannot be performed immediately, revoke or downgrade Contributor permissions until a patch is installed.
  • Audit existing pages and posts for stored scripts, removing any malicious widget content or replacing it with sanitized text.

Generated by OpenCVE AI on October 28, 2026 at 07:52 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 09:30:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions page Builder By Siteorigin
Vendors & Products Wordpress-extensions
Wordpress-extensions page Builder By Siteorigin

Wed, 28 Oct 2026 08:15:00 +0000

Type Values Removed Values Added
Weaknesses CWE-79

Wed, 28 Oct 2026 06:15:00 +0000

Type Values Removed Values Added
Description The Page Builder by SiteOrigin WordPress plugin before 2.38.0 does not sanitize or escape a widget property before storing it and outputting it in the page builder interface, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks against higher-privileged users who open the affected post in the editor.
Title Page Builder by SiteOrigin < 2.38.0 - Contributor+ Stored XSS via panels_info.class
References

Subscriptions

Wordpress-extensions Page Builder By Siteorigin
cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-28T06:00:23.013Z

Reserved: 2026-10-14T10:40:32.327Z

Link: CVE-2026-110506

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T06:16:33.543

Modified: 2026-10-28T06:16:33.543

Link: CVE-2026-110506

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T09:15:14Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')