Description
The Page Builder by SiteOrigin WordPress plugin before 2.38.0 does not restrict the query arguments users can add to its Post Loop widget or limit the loop to posts they are allowed to read, which could allow users with the contributor role and above to read the content of other users' draft, pending, scheduled and private posts and pages.
Published: 2026-10-28
Score: n/a
EPSS: n/a
KEV: No
Impact: Sensitive Data Disclosure
Action: Immediate Patch
AI Analysis

Impact

The Page Builder by SiteOrigin WordPress plugin, prior to version 2.38.0, accepts arbitrary query arguments in its Post Loop widget without proper validation or restriction of query scope. Contributors and higher roles can craft requests that bypass the default post filtering, leading to exposure of draft, pending, scheduled, and private posts and pages. This enables attackers with authorized contribution access to read content they should not normally see. The flaw is rooted in a lack of input validation and access control, aligning with the CWE‑200 Sensitive Data Exposure weakness.

Affected Systems

Any WordPress installation that includes the Page Builder by SiteOrigin plugin older than 2.38.0 is impacted. Users with the contributor role or higher who can edit the widget are able to trigger the disclosure. The vulnerability is vendor‑specific to the Page Builder by SiteOrigin plugin; other plugins or themes are not directly affected by this issue.

Risk and Exploitability

The vulnerability’s CVSS score is not provided, but the potential to read private content is serious for confidentiality. EPSS information is unavailable, and the flaw is not listed in CISA’s KEV catalog, indicating no confirmed widespread exploitation yet. Attackers need legitimate contributor access or higher to inject malicious query parameters, after which the plugin will return the query results. The lack of hardening on the widget’s query handling makes exploitation straightforward once the attacker has user credentials with sufficient rights.

Generated by OpenCVE AI on October 28, 2026 at 07:52 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Page Builder by SiteOrigin plugin to version 2.38.0 or later, where query arguments are properly validated and post visibility is respected.
  • If an immediate upgrade is not possible, remove or disable the Post Loop widget for contributor and lower roles, or restrict those users from editing widgets altogether.
  • Consider further hardening by limiting the permissions granted to contributor roles, ensuring they cannot modify widget parameters or read private content.

Generated by OpenCVE AI on October 28, 2026 at 07:52 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 08:15:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions page Builder By Siteorigin
Weaknesses CWE-200
Vendors & Products Wordpress-extensions
Wordpress-extensions page Builder By Siteorigin

Wed, 28 Oct 2026 06:15:00 +0000

Type Values Removed Values Added
Description The Page Builder by SiteOrigin WordPress plugin before 2.38.0 does not restrict the query arguments users can add to its Post Loop widget or limit the loop to posts they are allowed to read, which could allow users with the contributor role and above to read the content of other users' draft, pending, scheduled and private posts and pages.
Title Page Builder by SiteOrigin < 2.38.0 - Contributor+ Sensitive Data Disclosure via Post Loop Widget Query Arguments
References

Subscriptions

Wordpress-extensions Page Builder By Siteorigin
cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-28T06:00:23.185Z

Reserved: 2026-10-14T10:40:35.709Z

Link: CVE-2026-110507

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T06:16:33.657

Modified: 2026-10-28T06:16:33.657

Link: CVE-2026-110507

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T08:00:17Z

Weaknesses
  • CWE-200

    Exposure of Sensitive Information to an Unauthorized Actor