Description
The Premium Packages – Sell Digital Products Securely plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'note' parameter in all versions up to, and including, 7.2.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit bypasses tag-based filtering because the payload is stored as a hex-escaped sequence (e.g., \x3cimg onerror=...\x3e) that sanitize_textarea_field does not strip, and is only decoded back into a live HTML tag by stripcslashes() during admin rendering — after all sanitization has occurred.
Published: 2026-10-16
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Update
AI Analysis

Impact

The Premium Packages – Sell Digital Products Securely plugin contains a stored cross‑site scripting flaw that can be triggered when an authenticated user adds an order note containing a specially encoded payload. The plugin sanitizes input with a function that leaves hexadecimal‑escaped sequences intact and only decodes them later when rendering the page for administrators. This allows an attacker to store a malicious script that will execute on the next visit of any user who can view the note, enabling session hijacking or defacement.

Affected Systems

WordPress sites running the Premium Packages plugin version 7.2.8 or earlier are affected. All releases up to and including 7.2.8 lack the proper sanitization required to prevent the XSS payload from being stored and later executed.

Risk and Exploitability

The CVSS score of 6.4 indicates a medium severity. The EPSS score is not available and the vulnerability is not listed in the CISA KEV catalog, suggesting no known public exploits yet. However, exploitation requires only authenticated access with subscriber‑level permissions, which is commonly granted to regular users. The attacker exploits the flaw by adding an order note with hex‑escaped malicious content; the note is stored, later decoded, and rendered as executable code in the browser. Because the payload runs in the context of any user who views the note, it can lead to credential theft, session hijacking, or site defacement. Given the breadth of sites using this plugin, the potential impact is considerable, especially when combined with other web application weaknesses.

Generated by OpenCVE AI on October 16, 2026 at 14:05 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Premium Packages to a version newer than 7.2.8 that addresses the XSS flaw.
  • If an upgrade is not yet available, patch the plugin by editing order‑notes.php to apply esc_html() or a similar escape function before storing user input.
  • Restrict the ability to add order notes to administrators only; disable or remove subscriber‑level note‑creation privileges.
  • Implement a strict Content Security Policy and other XSS‑mitigation controls site‑wide to reduce the risk of similar vulnerabilities in other components.

Generated by OpenCVE AI on October 16, 2026 at 14:05 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 23 Oct 2026 15:00:00 +0000

Type Values Removed Values Added
First Time appeared Codename065
Codename065 premium Packages – Sell Digital Products Securely
Wordpress-extensions
Wordpress-extensions premium Packages
Vendors & Products Codename065
Codename065 premium Packages – Sell Digital Products Securely
Wordpress-extensions
Wordpress-extensions premium Packages

Fri, 16 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 16 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The Premium Packages – Sell Digital Products Securely plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'note' parameter in all versions up to, and including, 7.2.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit bypasses tag-based filtering because the payload is stored as a hex-escaped sequence (e.g., \x3cimg onerror=...\x3e) that sanitize_textarea_field does not strip, and is only decoded back into a live HTML tag by stripcslashes() during admin rendering — after all sanitization has occurred.
Title Premium Packages <= 7.2.8 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Order Notes
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

Codename065 Premium Packages – Sell Digital Products Securely
Wordpress-extensions Premium Packages
cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-16T14:39:03.424Z

Reserved: 2026-10-14T13:09:43.948Z

Link: CVE-2026-110664

cve-icon Vulnrichment

Updated: 2026-10-16T14:34:11.925Z

cve-icon NVD

Status : Deferred

Published: 2026-10-16T07:17:11.490

Modified: 2026-10-16T15:17:11.657

Link: CVE-2026-110664

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-23T14:45:17Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')