Description
A vulnerability was determined in OpenSIPS up to 3.6.8/4.0.1. The impacted element is the function rtpproxy_offer/rtpproxy_answer of the component rtpproxy. This manipulation causes out-of-bounds read. The attack may be initiated remotely. Upgrading to version 3.6.9 and 4.0.2 is sufficient to resolve this issue. It is advisable to upgrade the affected component.
Published: 2026-10-14
Score: 6.9 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Information disclosure via out-of-bounds read
Action: Patch immediately
AI Analysis

Impact

The vulnerability is an out-of-bounds read triggered in the rtpproxy_offer/rtpproxy_answer functions within OpenSIPS. Attackers can send crafted RTP proxy requests to cause the component to read memory beyond the intended buffer, potentially exposing internal data or destabilizing the application. This results in unintended data disclosure and possible instability, representing a buffer overread (CWE‑125) and insufficient bounds checking (CWE‑119).

Affected Systems

OpenSIPS versions up to 3.6.8 and 4.0.1 are impacted. The fix is available in 3.6.9 and 4.0.2. The vulnerable component is the rtpproxy module that handles SIP RTP proxy operations.

Risk and Exploitability

The CVSS score is 6.9, indicating a medium severity. Exploitation probability is unknown because the EPSS score is not available, but the attack can be initiated remotely via crafted RTP proxy messages. The vulnerability is not listed in CISA KEV, suggesting no publicly known exploits yet, though the remote nature and memory read make it worthwhile to mitigate promptly.

Generated by OpenCVE AI on October 15, 2026 at 12:43 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Apply the OpenSIPS update to version 3.6.9 or 4.0.2 or later
  • If an upgrade cannot be performed immediately, disable or restrict the rtpproxy component to trusted IP ranges
  • Monitor SIP RTP traffic and server logs for abnormal rtpproxy requests and block suspicious sources

Generated by OpenCVE AI on October 15, 2026 at 12:43 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 15 Oct 2026 16:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 14 Oct 2026 20:45:00 +0000

Type Values Removed Values Added
Description A vulnerability was determined in OpenSIPS up to 3.6.8/4.0.1. The impacted element is the function rtpproxy_offer/rtpproxy_answer of the component rtpproxy. This manipulation causes out-of-bounds read. The attack may be initiated remotely. Upgrading to version 3.6.9 and 4.0.2 is sufficient to resolve this issue. It is advisable to upgrade the affected component.
Title OpenSIPS rtpproxy rtpproxy_answer out-of-bounds
First Time appeared Opensips
Opensips opensips
Weaknesses CWE-119
CWE-125
CPEs cpe:2.3:a:opensips:opensips:*:*:*:*:*:*:*:*
Vendors & Products Opensips
Opensips opensips
References
Metrics cvssV2_0

{'score': 7.5, 'vector': 'AV:N/AC:L/Au:N/C:P/I:P/A:P/E:ND/RL:OF/RC:C'}

cvssV3_0

{'score': 7.3, 'vector': 'CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C'}

cvssV3_1

{'score': 7.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C'}

cvssV4_0

{'score': 6.9, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X'}


Subscriptions

Opensips Opensips
cve-icon MITRE

Status: PUBLISHED

Assigner: VulDB

Published:

Updated: 2026-10-15T15:27:12.475Z

Reserved: 2026-10-14T13:25:17.537Z

Link: CVE-2026-110679

cve-icon Vulnrichment

Updated: 2026-10-15T15:27:08.891Z

cve-icon NVD

Status : Deferred

Published: 2026-10-14T21:17:36.253

Modified: 2026-10-15T16:17:45.843

Link: CVE-2026-110679

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-22T22:45:13Z

Weaknesses
  • CWE-119

    Improper Restriction of Operations within the Bounds of a Memory Buffer

  • CWE-125

    Out-of-bounds Read