Description
The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'media:group/media:description (XML element in the imported feed)' parameter in all versions up to, and including, 5.2.12 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires an administrator to configure a Feed-to-Post import pointing at an attacker-controlled feed URL and trigger the import via the Run Now action or setup wizard, which is the plugin's standard configuration flow.
Published: 2026-10-29
Score: 4.7 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Apply Patch
AI Analysis

Impact

Stored cross‑site scripting is caused by insufficient sanitization of the media:description XML element in imported feeds. After an administrator imports a feed, malicious script stored in that element is rendered in the site’s front‑end, causing the script to run in any visitor’s browser.

Affected Systems

The issue affects the WordPress plugin RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator from vendors themeisle, in all releases up to and including 5.2.12.

Risk and Exploitability

With a CVSS score of 4.7, this vulnerability is considered medium. The EPSS score is not available, and the vulnerability is not listed in the CISA KEV catalog. An attacker that can supply a malicious feed URL can inject scripts that execute whenever any site visitor loads the affected content; however, the attacker needs the site administrator to trigger the import, limiting the attack window. The primary attack vector is remote, contingent on an unauthenticated attacker controlling a feed and the administrator executing the import.

Generated by OpenCVE AI on October 29, 2026 at 10:24 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the plugin to version 5.2.13 or later, where the input sanitization is fixed.
  • If an upgrade is not immediately possible, delete or edit existing posts that contain the injected media:description content.
  • Restrict the Feed‑to‑Post import feature to trusted administrators and monitor the import queue for suspicious activity.

Generated by OpenCVE AI on October 29, 2026 at 10:24 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 29 Oct 2026 09:45:00 +0000

Type Values Removed Values Added
Description The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'media:group/media:description (XML element in the imported feed)' parameter in all versions up to, and including, 5.2.12 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires an administrator to configure a Feed-to-Post import pointing at an attacker-controlled feed URL and trigger the import via the Run Now action or setup wizard, which is the plugin's standard configuration flow.
Title RSS Aggregator by Feedzy <= 5.2.12 - Unauthenticated Stored Cross-Site Scripting via YouTube media:description Feed Element
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 4.7, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-29T10:45:41.659Z

Reserved: 2026-10-14T14:28:08.349Z

Link: CVE-2026-110707

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-29T10:17:02.877

Modified: 2026-10-29T10:17:02.877

Link: CVE-2026-110707

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-29T10:30:11Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')