Description
Netgate pfSense CE 2.3.0 through 2.9.0 contains a stored cross-site scripting vulnerability that allows authenticated users with Firewall: Rules or NAT: Port Forward privileges to inject scripts via the separator color field. Attackers can submit a crafted separator[] color value that display_separator() renders unencoded into class attributes, executing in administrators' browsers to perform WebGUI actions with their privileges.
Published: 2026-10-15
Score: 4.8 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch
AI Analysis

Impact

The vulnerability allows an authenticated user to inject arbitrary client‑side code through the separator color field used for firewall and NAT rules. When the stored color value is processed by display_separator(), it is placed directly into a class attribute without encoding, enabling scripts to run in the browser of any administrator who visits the page. This can steal session data, manipulate the WebGUI, or perform privileged actions without the user's knowledge. “

Affected Systems

Netgate pfSense CE versions 2.3.0 through 2.9.0 are affected. Any installation using the default firewall or NAT rule interface within these releases is vulnerable. The issue does not exist in releases prior to 2.3.0 or in any patch that follows 2.9.0 if it addresses the bug.

Risk and Exploitability

The CVSS score of 4.8 indicates a moderate severity, and the EPSS score of less than 1% suggests that exploitation is currently unlikely. The vulnerability is not listed in the CISA KEV catalog. Attackers require authentication with either Firewall: Rules or NAT: Port Forward privileges to submit the malicious separator[] value, so the attack vector is a web‑based administrative UI that accepts privileged input. Once a payload is stored, any administrator who views the affected rule list will trigger script execution.

Generated by OpenCVE AI on October 16, 2026 at 17:11 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Check for a vendor‑issued patch or newer pfSense CE release that fixes the separator color XSS.
  • If no patch is available, remove or limit the separator color feature by restricting the rule configuration to users without the required privileges.
  • Upgrade the pfSense CE installation to the latest supported release that resolves this stored XSS flaw.

Generated by OpenCVE AI on October 16, 2026 at 17:11 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 19 Oct 2026 21:00:00 +0000

Type Values Removed Values Added
First Time appeared Pfsense
Pfsense pfsense
CPEs cpe:2.3:a:pfsense:pfsense:*:*:*:*:community:*:*:*
Vendors & Products Pfsense
Pfsense pfsense

Thu, 15 Oct 2026 19:00:00 +0000

Type Values Removed Values Added
Description Netgate pfSense CE 2.3.0 through 2.9.0 contains a stored cross-site scripting vulnerability that allows authenticated users with Firewall: Rules or NAT: Port Forward privileges to inject scripts via the separator color field. Attackers can submit a crafted separator[] color value that display_separator() renders unencoded into class attributes, executing in administrators' browsers to perform WebGUI actions with their privileges.
Title Netgate pfSense CE 2.3.0 through 2.9.0 Stored XSS via Separator Color
First Time appeared Netgate
Netgate pfsense
Weaknesses CWE-79
CPEs cpe:2.3:a:netgate:pfsense:*:*:*:*:*:*:*:*
Vendors & Products Netgate
Netgate pfsense
References
Metrics cvssV3_1

{'score': 4.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N'}

cvssV4_0

{'score': 4.8, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N'}


cve-icon MITRE

Status: PUBLISHED

Assigner: VulnCheck

Published:

Updated: 2026-10-21T01:11:30.708Z

Reserved: 2026-10-15T18:21:24.351Z

Link: CVE-2026-111232

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Analyzed

Published: 2026-10-15T19:17:36.257

Modified: 2026-10-21T01:17:20.563

Link: CVE-2026-111232

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-17T14:00:09Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')