Description
The Appointment Booking Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'vs_text_submitbtn' parameter in all versions up to, and including, 1.4.05 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the attacker to be assigned as a calendar owner, a per-user grant that any administrator can extend to users as low as Subscriber level through the plugin's calendar list screen. Exploitation by attackers with subscriber-level access and above requires that an administrator has assigned the attacker's account as owner (`conwer`) of a calendar via the plugin's calendar list screen; the plugin's UI lists all registered users regardless of role, so a Subscriber can be assigned. On a default installation, where that is not configured, the vulnerability requires attackers with editor-level access and above.
Published: 2026-10-28
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch Immediately
AI Analysis

Impact

The Appointment Booking Calendar plugin for WordPress is vulnerable to stored cross‑site scripting via the vs_text_submitbtn parameter. Insufficient input sanitization and output escaping allow an authenticated user with subscriber‑level access or higher to inject arbitrary web scripts into pages that will execute whenever a user accesses an affected page. The flaw requires the attacker to be assigned as the calendar owner, a per‑user grant that administrators can extend to subscriber accounts.

Affected Systems

All WordPress sites running the Appointment Booking Calendar plugin version 1.4.05 or earlier are affected. The plugin is developed by codepeople and is a widely used calendar solution in WordPress environments. Users who have been granted calendar owner rights – including subscriber accounts that have been assigned ownership by an administrator – are susceptible, as any subscriber account can be made an owner through the plugin’s calendar list screen.

Risk and Exploitability

The CVSS score of 6.4 indicates medium severity. No EPSS data is available, so the current exploitation probability is unknown. The vulnerability is not listed in the CISA KEV catalog. Exploitation requires an authenticated attacker who has been granted ownership of a calendar; an administrator or editor must assign the attacker’s user account as owner via the plugin’s calendar list screen. Because the attack surface depends on such an assignment, the potential impact is limited to sites where subscriber accounts have been granted calendar owner privileges, but a successful exploit would allow arbitrary script execution for any user who views the affected page.

Generated by OpenCVE AI on October 28, 2026 at 05:50 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Appointment Booking Calendar plugin to any release newer than 1.4.05, ensuring that the input sanitization and output escaping fix is applied.
  • Restrict calendar owner privileges for subscriber accounts; enforce that only administrators or editors assign ownership to prevent low‑privilege users from inserting malicious payloads.
  • Implement a Content Security Policy that disallows inline scripts and whitelists trusted script sources, mitigating the impact of any residual XSS vectors.

Generated by OpenCVE AI on October 28, 2026 at 05:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 04:00:00 +0000

Type Values Removed Values Added
Description The Appointment Booking Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'vs_text_submitbtn' parameter in all versions up to, and including, 1.4.05 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the attacker to be assigned as a calendar owner, a per-user grant that any administrator can extend to users as low as Subscriber level through the plugin's calendar list screen. Exploitation by attackers with subscriber-level access and above requires that an administrator has assigned the attacker's account as owner (`conwer`) of a calendar via the plugin's calendar list screen; the plugin's UI lists all registered users regardless of role, so a Subscriber can be assigned. On a default installation, where that is not configured, the vulnerability requires attackers with editor-level access and above.
Title Appointment Booking Calendar <= 1.4.05 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'vs_text_submitbtn' Parameter
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T03:42:54.736Z

Reserved: 2026-10-16T14:49:01.044Z

Link: CVE-2026-111727

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T04:17:57.220

Modified: 2026-10-28T04:17:57.220

Link: CVE-2026-111727

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T06:00:15Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')