Description
Cross-Site Request Forgery (CSRF) vulnerability in Aman FunnelKit Automations wp-marketing-automations allows Cross Site Request Forgery.This issue affects FunnelKit Automations: from n/a through 3.8.5.2.
Published: 2026-10-26
Score: 8.8 High
EPSS: n/a
KEV: No
Impact: Unauthorized Action
Action: Immediate Patch
AI Analysis

Impact

Cross‑Site Request Forgery (CSRF) is present in the Aman FunnelKit Automations WordPress plugin through version 3.8.5.2. The vulnerability allows an attacker to fabricate requests that a victim’s authenticated browser will execute, potentially enabling the attacker to perform any action that the victim can normally perform in the plugin, such as modifying marketing automation rules or setting. Because the input validation for CSRF tokens is missing, this flaw can result in unauthorized changes to the site’s configuration without the user’s consent. The CVSS score of 8.8 reflects the high severity and potential for widespread impact on data integrity and site functionality.

Affected Systems

The affected product is the Aman FunnelKit Automations WordPress plugin, commonly installed as part of the wp‑marketing‑automations suite. Any deployment of this plugin up to and including version 3.8.5.2 is vulnerable; newer releases such as 3.8.6 or later contain the fix.

Risk and Exploitability

The CVSS base score of 8.8 indicates a high‑severity threat. The EPSS score is not provided, and the vulnerability is not listed in CISA’s KEV catalog, implying that a known exploit is not yet publicly documented. The likely attack vector is remote: an attacker can embed a crafted link or form that a logged‑in user will unknowingly submit, leveraging their authenticated session to perform privileged actions. Even without a publicly available exploit, the high score suggests that the flaw could be weaponised if an attacker examines traffic to identify request parameters. Administrators should treat this as a high risk until a patch is applied.

Generated by OpenCVE AI on October 26, 2026 at 10:24 UTC.

Remediation

Vendor Solution

Update the WordPress FunnelKit Automations plugin to the latest available version (at least 3.8.6).


OpenCVE Recommended Actions

  • Update the FunnelKit Automations WordPress plugin to version 3.8.6 or later.
  • If the update cannot be applied immediately, disable the FunnelKit Automations plugin to block CSRF exploitation until the patch is installed.
  • After the update, test all automated marketing actions to confirm they function correctly and that the new version does not introduce unintended behavior.

Generated by OpenCVE AI on October 26, 2026 at 10:24 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 26 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Cross-Site Request Forgery (CSRF) vulnerability in Aman FunnelKit Automations wp-marketing-automations allows Cross Site Request Forgery.This issue affects FunnelKit Automations: from n/a through 3.8.5.2.
Title WordPress FunnelKit Automations plugin <= 3.8.5.2 - Cross Site Request Forgery (CSRF) vulnerability
Weaknesses CWE-352
References
Metrics cvssV3_1

{'score': 8.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-26T10:13:38.533Z

Reserved: 2026-10-17T00:17:57.461Z

Link: CVE-2026-111841

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-26T09:16:34.207

Modified: 2026-10-26T09:16:34.207

Link: CVE-2026-111841

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-26T10:30:10Z

Weaknesses
  • CWE-352

    Cross-Site Request Forgery (CSRF)