Description
The Media Library Assistant WordPress plugin before 3.44 does not escape one of its shortcode attributes before outputting it in an attribute of generated links, allowing users with the Contributor role and above to perform Stored Cross-Site Scripting attacks.
Published: 2026-11-01
Score: n/a
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The Media Library Assistant WordPress plugin, in versions before 3.44, fails to properly escape a shortcode attribute before inserting it into the href attribute of generated links. This oversight enables users with the Contributor role or higher to store malicious JavaScript that will be executed whenever the link is rendered in a browser. The resulting vulnerability can lead to theft of user credentials, session hijacking, or further compromise of the site if the attacker injects additional payloads. The weakness aligns with the Cross‑Site Scripting category, as the attacker injects executable code into a trusted context.

Affected Systems

Any WordPress site running Media Library Assistant prior to version 3.44 is affected. The plugin is not associated with a traditional vendor; it is distributed as a community WordPress plugin. Site administrators who have relied on the older plugin version and assigned Contributor roles to users are exposed.

Risk and Exploitability

While no official CVSS score is supplied, the nature of Stored XSS suggests a high severity assessment. The attack vector is not explicitly detailed in the advisory, but the description indicates that the malicious code is injected via a shortcode and surfaces when the link is rendered, implying that exploiting the vulnerability may require legitimate access to submit shortcodes. No EPSS data is available and the vulnerability is not listed in CISA’s KEV catalog. Nonetheless, the potential impact on confidentiality, integrity, and availability warrants rapid remediation.

Generated by OpenCVE AI on November 1, 2026 at 07:50 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Media Library Assistant to version 3.44 or later to receive the XSS fix
  • Remove any existing malicious shortcodes or previously injected JavaScript from posts and pages
  • Restrict Contributor role permissions if possible, ensuring contributors cannot add or edit shortcodes

Generated by OpenCVE AI on November 1, 2026 at 07:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 01 Nov 2026 08:15:00 +0000

Type Values Removed Values Added
Weaknesses CWE-79

Sun, 01 Nov 2026 06:15:00 +0000

Type Values Removed Values Added
Description The Media Library Assistant WordPress plugin before 3.44 does not escape one of its shortcode attributes before outputting it in an attribute of generated links, allowing users with the Contributor role and above to perform Stored Cross-Site Scripting attacks.
Title Media Library Assistant < 3.44 - Contributor+ Stored XSS via mla_item_parameter Shortcode Attribute
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-11-01T06:00:22.885Z

Reserved: 2026-10-20T08:46:33.673Z

Link: CVE-2026-113482

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-01T05:18:57.247

Modified: 2026-11-01T05:18:57.247

Link: CVE-2026-113482

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-01T08:00:03Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')