Description
Improper isolation or compartmentalization vulnerability in Apache Syncope.



An administrator with adequate entitlements for Implementations can create a malicious Groovy class running untrusted code on a separate Thread, thus bypassing the Groovy security sandbox.



This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0-M0 through 4.1.3.



Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue.
Published: 2026-11-02
Score: n/a
EPSS: n/a
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

The vulnerability is an improper isolation flaw that allows an administrator with adequate entitlements to create a malicious Groovy class that runs untrusted code on a separate thread, thereby bypassing the Groovy security sandbox and enabling remote code execution.

Affected Systems

Affected versions of Apache Syncope include all releases from 3.0.0‑M0 to 3.0.16, from 4.0.0‑M0 to 4.0.8, and from 4.1.0‑M0 to 4.1.3. The flaw exists in the ProcessGroovyMethodsSandbox component of these versions.

Risk and Exploitability

The CVSS score is not listed, and the EPSS score is unavailable, but the vulnerability is not in the KEV catalog, indicating it is not a known exploited vulnerability. Exploit requires administrative credentials with the ability to implement custom Groovy classes, making the attack vector authenticated and privilege‑escalation‑like. Once the malicious code runs on a separate thread, it can execute arbitrary actions with the privileges of the Syncope daemon, potentially compromising confidentiality, integrity, and availability of the underlying system.

Generated by OpenCVE AI on November 2, 2026 at 14:23 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade to Apache Syncope 4.0.9 or 4.1.4, which contain the fix for this vulnerability.
  • Disable or heavily restrict Groovy script execution capabilities so that custom classes cannot be instantiated to run untrusted code.
  • Enforce least privilege for administrative accounts so they cannot create or deploy custom Groovy implementations.
  • Monitor Syncope logs for unexpected Groovy class creation or thread activity as an additional detection measure.

Generated by OpenCVE AI on November 2, 2026 at 14:23 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 02 Nov 2026 14:45:00 +0000

Type Values Removed Values Added
First Time appeared Apache
Apache syncope
Vendors & Products Apache
Apache syncope

Mon, 02 Nov 2026 13:30:00 +0000

Type Values Removed Values Added
Description Improper isolation or compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class running untrusted code on a separate Thread, thus bypassing the Groovy security sandbox. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0-M0 through 4.1.3. Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue.
Title Apache Syncope: RCE via ProcessGroovyMethodsSandbox bypass
Weaknesses CWE-653
References

cve-icon MITRE

Status: PUBLISHED

Assigner: apache

Published:

Updated: 2026-11-02T13:10:11.700Z

Reserved: 2026-10-20T15:05:47.375Z

Link: CVE-2026-113687

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-02T14:17:35.790

Modified: 2026-11-02T14:17:35.790

Link: CVE-2026-113687

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-02T14:30:11Z

Weaknesses
  • CWE-653

    Improper Isolation or Compartmentalization