Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPVibes AnyWhere Elementor anywhere-elementor allows Stored XSS.This issue affects AnyWhere Elementor: from n/a through 1.3.0.
Published: 2026-11-08
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS) leading to script execution in visitors’ browsers
Action: Patch Now
AI Analysis

Impact

The vulnerability allows an attacker to inject malicious JavaScript that is stored within content managed by the WPVibes AnyWhere Elementor plugin. When users load affected pages, the script executes in their browsers, potentially enabling defacement, cookie theft, or session hijacking. The flaw stems from improper neutralization of user input during page generation, a classic stored XSS scenario. No escalation of system privileges is achieved; the impact is confined to victim browsers. The listed weakness is CWE‑79.

Affected Systems

WPVibes AnyWhere Elementor plugin, versions up to and including 1.3.0. The affected range is from the earliest release through 1.3.0. Users running 1.3.1 or later are not impacted.

Risk and Exploitability

The CVSS score of 6.5 marks this as a moderate‑severity issue. The EPSS score is unavailable, and it is not listed in CISA KEV, suggesting limited pre‑existing exploitation activity. Attackers would need to supply input via the plugin’s interface; therefore the likelihood of exploitation depends on the plugin’s usage and exposure. Given the web‑based nature of the vulnerability, the principal vector is a web application, and the attack can be performed by unauthenticated or authenticated users if the plugin accepts input from those user types.

Generated by OpenCVE AI on November 8, 2026 at 17:23 UTC.

Remediation

Vendor Solution

Update the WordPress AnyWhere Elementor plugin to the latest available version (at least 1.3.1).


OpenCVE Recommended Actions

  • Update the WPVibes AnyWhere Elementor plugin to version 1.3.1 or later.
  • If an immediate update is not possible, deactivate or remove the plugin to stop the injection vector.
  • Audit any stored content for previously submitted input and sanitize or delete malicious entries to eliminate residual XSS payloads.

Generated by OpenCVE AI on November 8, 2026 at 17:23 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 08 Nov 2026 16:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPVibes AnyWhere Elementor anywhere-elementor allows Stored XSS.This issue affects AnyWhere Elementor: from n/a through 1.3.0.
Title WordPress AnyWhere Elementor plugin <= 1.3.0 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-08T18:55:19.303Z

Reserved: 2026-10-21T00:23:03.975Z

Link: CVE-2026-114188

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-08T16:16:37.090

Modified: 2026-11-08T16:16:37.210

Link: CVE-2026-114188

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-08T17:30:15Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')