Description
Improper neutralization of special elements used in an SQL command ('SQL injection') vulnerability in Apache Syncope.



This CVE covers an incomplete fix for CVE-2026-77051: an administrator with adequate entitlements can achieve execution of arbitrary SQL via stacked queries, leveraging unsanitized opEvent parameters.
Reference: https://cve.org/CVERecord?id=CVE-2026-77051

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0-M0 through 4.1.3.



Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue.
Published: 2026-11-02
Score: n/a
EPSS: n/a
KEV: No
Impact: Remote Code Execution
Action: Patch Now
AI Analysis

Impact

CVE-2026-114364 exposes an SQL injection flaw in Apache Syncope’s Audit Events search feature. Unvalidated values supplied through the opEvent parameter allow an attacker who has sufficient administrative entitlements to inject arbitrary SQL commands via stacked queries. This vulnerability, identified as CWE‑89, can enable data exfiltration, manipulation, or potentially execution of arbitrary code on the database server if the underlying system privileges permit.

Affected Systems

Affected releases span multiple major lines of Apache Syncope. Versions from 3.0.0‑M0 through 3.0.16, from 4.0.0‑M0 through 4.0.8, and from 4.1.0‑M0 through 4.1.3 are vulnerable. An administrator should verify the current Patch version and plan to move to a fixed release.

Risk and Exploitability

The CVSS score is not provided, and EPSS is unavailable, indicating no real‑world exploitation data at this time. The flaw is not in CISA’s KEV catalog. Attackers would need authenticated access to the search API with appropriate privileges, making the threat surface limited to privileged users. Nonetheless, because the flaw permits arbitrary SQL execution, the potential impact warrants prompt remediation.

Generated by OpenCVE AI on November 2, 2026 at 14:23 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Apache Syncope to version 4.0.9 or 4.1.4, the upstream fix for this issue.
  • Limit access to the Audit Events search endpoint so that only the minimal set of users with legitimate business need can invoke it.
  • If an immediate upgrade is not possible, consider disabling the opEvent query parameter or the entire Audit Events search functionality until the patch is applied to prevent exploitation.

Generated by OpenCVE AI on November 2, 2026 at 14:23 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 02 Nov 2026 13:30:00 +0000

Type Values Removed Values Added
Description Improper neutralization of special elements used in an SQL command ('SQL injection') vulnerability in Apache Syncope. This CVE covers an incomplete fix for CVE-2026-77051: an administrator with adequate entitlements can achieve execution of arbitrary SQL via stacked queries, leveraging unsanitized opEvent parameters. Reference: https://cve.org/CVERecord?id=CVE-2026-77051 This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0-M0 through 4.1.3. Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue.
Title Apache Syncope: SQL injection via unsanitized opEvent in Audit Events search
Weaknesses CWE-89
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: apache

Published:

Updated: 2026-11-02T13:12:27.512Z

Reserved: 2026-10-21T09:16:02.274Z

Link: CVE-2026-114364

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-02T14:17:35.930

Modified: 2026-11-02T14:17:35.930

Link: CVE-2026-114364

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-02T14:30:11Z

Weaknesses
  • CWE-89

    Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')