Description
Privilege Defined With Unsafe Actions vulnerability in Drupal Custom Formatters allows Privilege Escalation. This issue affects Custom Formatters versions: from 0.0.0 to 4.2.1.
Published: 2026-10-30
Score: n/a
EPSS: n/a
KEV: No
Impact: Privilege Escalation
Action: Immediate Patch
AI Analysis

Impact

This vulnerability arises from privilege defined with unsafe actions in the Drupal Custom Formatters module, allowing an attacker to increase privileges beyond their intended level. The issue permits escalation of permissions, potentially granting administrative capabilities to an unauthorized user. The description does not reference remote code execution though the advisory title mentions it; the effective impact is limited to privilege escalation as specified.

Affected Systems

The Drupal Custom Formatters module is affected, covering all released versions from 0.0.0 through 4.2.1. Any site using the module within this version range is vulnerable.

Risk and Exploitability

No CVSS score is available, and the EPSS is not reported, making precise risk calculation difficult. The vulnerability is not listed in the CISA KEV catalog, suggesting it is not publicly exploited at large scale yet. Based on the described flaw and common exploitation patterns for unsafe actions, the attack vector is likely application-level: an attacker with some authenticated access or the ability to create or edit formatted content can trigger the privilege escalation. The impact is mainly potential unauthorized elevation to higher user roles, which can lead to full site takeover if the elevated privileges grant site-wide control.

Generated by OpenCVE AI on October 30, 2026 at 04:56 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Custom Formatters to the latest available release, removing all versions up to 4.2.1.
  • Reconfigure the module to eliminate or disable any 'unsafe actions' that grant elevated privileges in formatter definitions.
  • Audit all user accounts to ensure the principle of least privilege is enforced, reducing the chance of accidental privilege escalation via the formatter.

Generated by OpenCVE AI on October 30, 2026 at 04:56 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

References
History

Fri, 30 Oct 2026 03:30:00 +0000

Type Values Removed Values Added
Description Privilege Defined With Unsafe Actions vulnerability in Drupal Custom Formatters allows Privilege Escalation. This issue affects Custom Formatters versions: from 0.0.0 to 4.2.1.
Title Custom Formatters - Critical - Remote code execution - SA-CONTRIB-2026-225
Weaknesses CWE-267
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: drupal

Published:

Updated: 2026-10-30T03:09:44.167Z

Reserved: 2026-10-21T17:08:25.387Z

Link: CVE-2026-114524

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-30T04:18:10.953

Modified: 2026-10-30T04:18:10.953

Link: CVE-2026-114524

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T05:00:14Z

Weaknesses
  • CWE-267

    Privilege Defined With Unsafe Actions