Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Bootstrap allows Cross-Site Scripting (XSS). This issue affects Bootstrap versions: from 0.0.0 to 3.45.0.
Published: 2026-10-30
Score: n/a
EPSS: n/a
KEV: No
Impact: Cross-site scripting
Action: Update Module
AI Analysis

Impact

An improper neutralization of input during web page generation in Drupal Bootstrap allows attackers to inject malicious scripts into pages served to user browsers. The flaw lies in insufficient output encoding for user-supplied data, exposing sites to the classic cross‑site scripting attack model. When exploited, an attacker can execute arbitrary JavaScript in the victim’s context, enabling script‑based data theft, session hijacking, or defacement of the web page.

Affected Systems

Drupal users employing the Bootstrap theme module are affected. The vulnerability spans all released versions from the initial 0.0.0 release up to and including 3.45.0. Sites that have not yet upgraded past 3.45.0 should assess whether the module is installed and in use.

Risk and Exploitability

The flaw can be triggered by submitting crafted input through a web form or URL that is rendered by the Bootstrap module. While no public exploit has been observed and the EPSS score is not available, the vulnerability is present in all exposed versions, giving attackers ample opportunity to craft attacks. The vulnerability is not listed in the CISA KEV catalog and no confirmed public exploits are documented.

Generated by OpenCVE AI on October 30, 2026 at 04:41 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update Drupal Bootstrap to a version newer than 3.45.0.
  • If an immediate upgrade is not possible, configure the site to enforce strict output escaping for Bootstrap‑generated content, ensuring that all user‑supplied data is encoded before rendering.
  • Consider deploying a Web Application Firewall rule that blocks or sanitizes common XSS payloads targeting the Bootstrap module.

Generated by OpenCVE AI on October 30, 2026 at 04:41 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

References
History

Fri, 30 Oct 2026 03:30:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Bootstrap allows Cross-Site Scripting (XSS). This issue affects Bootstrap versions: from 0.0.0 to 3.45.0.
Title Bootstrap - Moderately critical - Cross-site scripting - SA-CONTRIB-2026-236
Weaknesses CWE-79
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: drupal

Published:

Updated: 2026-10-30T03:09:32.792Z

Reserved: 2026-10-21T17:08:25.388Z

Link: CVE-2026-114538

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-30T04:18:12.680

Modified: 2026-10-30T04:18:12.680

Link: CVE-2026-114538

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T04:45:06Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')