Description
Incorrect Authorization vulnerability in Drupal Frontend Editing allows Forceful Browsing. This issue affects Frontend Editing versions: from 0.0.0 to 1.9.3.
Published: 2026-10-30
Score: n/a
EPSS: n/a
KEV: No
Impact: Authorization bypass allowing forced browsing
Action: Apply patch
AI Analysis

Impact

Drupal's Frontend Editing module contains an incorrect authorization flaw that permits Forceful Browsing. Attackers can request URLs that should be protected, allowing them to view content meant for authenticated users or administrative pages. This is an authorization bypass that may expose sensitive data and obscure content integrity. The core weakness is described by CWE-863, indicating improper authorization checks.

Affected Systems

The flaw affects the Frontend Editing contributed module for Drupal. Versions from 0.0.0 through 1.9.3 are affected, covering all releases up to the latest listed version. Users running any of these versions should verify whether the module is installed and in use and determine the specific level of access granted to their roles.

Risk and Exploitability

Because no EPSS or KEV data is available, the public knowledge of exploitation is limited, but the vulnerability can be used without authentication through directed URL requests. Without the proper authorization check, an attacker can forcefully browse protected pages. While the severity is not quantified in CVSS terms, the potential to expose confidential content requires prompt remediation. The attack path is relatively straightforward once the module is active: sending crafted HTTP requests to restricted endpoints reveals the bypass.

Generated by OpenCVE AI on October 30, 2026 at 04:43 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade to Drupal Frontend Editing version 2.0.0 or later, if available, to eliminate the flawed authorization checks.
  • Configure role permissions so that only authorized personnel can access the Frontend Editing component.
  • Disable the Frontend Editing module entirely for sites that do not require frontend content editing capabilities.
  • Monitor access logs for suspicious HTTP requests to restricted pages and consider blocking malicious IPs or patterns.

Generated by OpenCVE AI on October 30, 2026 at 04:43 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

References
History

Fri, 30 Oct 2026 03:30:00 +0000

Type Values Removed Values Added
Description Incorrect Authorization vulnerability in Drupal Frontend Editing allows Forceful Browsing. This issue affects Frontend Editing versions: from 0.0.0 to 1.9.3.
Title Frontend Editing - Less critical - Access bypass - SA-CONTRIB-2026-241
Weaknesses CWE-863
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: drupal

Published:

Updated: 2026-10-30T03:09:27.605Z

Reserved: 2026-10-21T17:11:54.697Z

Link: CVE-2026-114553

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-30T04:18:15.593

Modified: 2026-10-30T04:18:15.593

Link: CVE-2026-114553

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T04:45:06Z

Weaknesses