Description
In EPICS Base release 7.0.10 and prior, an insufficient validation of element or length values in a network message can cause the application to read beyond the bounds of an allocated buffer. This may lead to denial of service and could expose adjacent memory contents.
Published: 2026-10-27
Score: 8.7 High
EPSS: n/a
KEV: No
Impact: Denial of Service
Action: Patch Update
AI Analysis

Impact

This vulnerability arises from inadequate validation of the length field in network messages received by EPICS Base. Because an attacker can send a message with a length that exceeds the actual payload, the application will read past the end of a buffer. The read can trigger a crash, resulting in denial of service, and the data read from adjacent memory may expose confidential information. The flaw fits CWE-130, Buffer Read Without Checking Size.

Affected Systems

Affected users run EPICS Base from the EPICS Community consortium. The vulnerability is present in release 7.0.10 and all earlier versions. The fix is available in the 7.0.11 release; hunters should update to this version.

Risk and Exploitability

With a CVSS score of 8.7 the vulnerability is considered High severity. The EPSS indicator is not available, and the flaw is not listed in CISA’s KEV catalog, indicating no known widespread exploitation. However, because the flaw can be triggered by crafted network traffic, an attacker with network access can deliver the malicious packet and cause a crash or memory disclosure. The risk depends on exposure of the EPICS Base service to external networks.

Generated by OpenCVE AI on October 27, 2026 at 18:43 UTC.

Remediation

Vendor Solution

The EPICS Community has made available updates to the epics-base GitHub repositories. Affected users should update to the 7.0.11 release. For more information, users should contact the EPICS Controls team https://epics-controls.org/support/. https://github.com/epics-base/epics-base/pull/934 https://github.com/epics-base/epics-base/pull/937 https://github.com/epics-base/pvDataCPP/pull/109


OpenCVE Recommended Actions

  • Upgrade EPICS Base to version 7.0.11 or later.
  • Ensure that all incoming messages are validated and that the length field is checked against the actual payload size, applying the patch if running older code.
  • Apply firewall rules or other network segmentation to restrict access to EPICS Base services to trusted hosts only, thereby limiting the potential attack surface.

Generated by OpenCVE AI on October 27, 2026 at 18:43 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 27 Oct 2026 17:00:00 +0000

Type Values Removed Values Added
Description In EPICS Base release 7.0.10 and prior, an insufficient validation of element or length values in a network message can cause the application to read beyond the bounds of an allocated buffer. This may lead to denial of service and could expose adjacent memory contents.
Title Improper handling of length parameter inconsistency in EPICS Base
Weaknesses CWE-130
References
Metrics cvssV3_1

{'score': 7.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'}

cvssV4_0

{'score': 8.7, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: icscert

Published:

Updated: 2026-10-27T16:51:59.240Z

Reserved: 2026-10-21T20:17:34.239Z

Link: CVE-2026-114597

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-27T17:16:58.840

Modified: 2026-10-27T17:16:58.840

Link: CVE-2026-114597

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-27T18:45:07Z

Weaknesses
  • CWE-130

    Improper Handling of Length Parameter Inconsistency