Description
In EPICS Base release 7.0.10 and prior, an insufficient validation of element or length values in a network message can cause the application to read beyond the bounds of an allocated buffer. This may lead to denial of service and could expose adjacent memory contents.
Published: 2026-10-27
Score: 8.7 High
EPSS: n/a
KEV: No
Impact: Denial of Service with potential memory disclosure
Action: Immediate Patch
AI Analysis

Impact

The vulnerability is a type‑confusion bug triggered by insufficient validation of element or length values in network messages received by EPICS Base. When an attacker sends a crafted message, the application may read data outside the bounds of an allocated buffer, leading to a denial of service and potentially leaking information from adjacent memory. This weakness can impair the availability of systems that rely on EPICS Base to control instrumentation.

Affected Systems

The affected product is EPICS Base from The EPICS Community, version 7.0.10 and earlier. Users running the 7.0.10 release or any prior release of EPICS Base on networked control systems are vulnerable. The vulnerability is specific to the EPICS Base component of the EPICS Controls framework.

Risk and Exploitability

The CVSS score of 8.7 marks this issue as high severity. The EPSS score is currently unavailable, and the vulnerability is not listed in the CISA KEV catalog. Attackers can exploit the flaw by sending malformed network messages to an EPICS Base service, which is likely to be routable on the network. The vulnerability can be triggered remotely without authentication, and because it corrupts memory, it may further expose sensitive data stored adjacent to the buffer.

Generated by OpenCVE AI on October 27, 2026 at 19:06 UTC.

Remediation

Vendor Solution

The EPICS Community has made available updates to the epics-base GitHub repositories. Affected users should update to the 7.0.11 release. For more information, users should contact the EPICS Controls team https://epics-controls.org/support/. https://github.com/epics-base/epics-base/pull/934 https://github.com/epics-base/epics-base/pull/937 https://github.com/epics-base/pvDataCPP/pull/109


OpenCVE Recommended Actions

  • Update EPICS Base to release 7.0.11 or later, ensuring the type‑confusion fix is applied.
  • Deploy the updated binaries on all hosts, replacing any legacy EPICS Base versions so that only the patched release remains active.
  • Restrict network access to EPICS Base services using segmentation or firewall rules so that only trusted hosts can communicate with them.

Generated by OpenCVE AI on October 27, 2026 at 19:06 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 27 Oct 2026 17:00:00 +0000

Type Values Removed Values Added
Description In EPICS Base release 7.0.10 and prior, an insufficient validation of element or length values in a network message can cause the application to read beyond the bounds of an allocated buffer. This may lead to denial of service and could expose adjacent memory contents.
Title Access of resource using incompatible type ('type confusion') in EPICS Base
Weaknesses CWE-843
References
Metrics cvssV3_1

{'score': 7.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'}

cvssV4_0

{'score': 8.7, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: icscert

Published:

Updated: 2026-10-27T16:53:28.775Z

Reserved: 2026-10-21T20:17:35.041Z

Link: CVE-2026-114598

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-27T17:16:59.003

Modified: 2026-10-27T17:16:59.003

Link: CVE-2026-114598

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-27T19:15:08Z

Weaknesses
  • CWE-843

    Access of Resource Using Incompatible Type ('Type Confusion')