Description
The Quttera ThreatSign – Web Malware Scanner for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'HTTP_USER_AGENT' parameter in all versions up to, and including, 4.1.0.48 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an administrator accesses an injected page.
Published: 2026-11-07
Score: 7.2 High
EPSS: n/a
KEV: No
Impact: Unauthenticated Stored Cross‑Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The vulnerability allows an unauthenticated attacker to inject arbitrary script into web pages through the HTTP_USER_AGENT header. Because the plugin fails to sanitize the header and to escape output, the injected script is permanently stored and subsequently executed whenever an administrator views a page. This is a classic stored cross‑site scripting flaw (CWE‑79) that can lead to credential theft, session hijacking, or defacement of the website.

Affected Systems

WordPress sites running the Quttera ThreatSign – Web Malware Scanner plugin, all releases up to and including version 4.1.0.48. The plugin can be present on any installation that has not yet applied the security update released after that version.

Risk and Exploitability

The flaw receives a CVSS score of 7.2, indicating high severity, and the EPSS score is not available, so the risk must be gauged mainly from CVSS and from the fact that it is unauthenticated. A directed malicious HTTP request that includes a crafted User‑Agent header can deliver the payload; the attack does not require prior privilege or user interaction. The vulnerability is not listed in the CISA KEV catalog at this time, but the combination of high CVSS and broad exposure makes it a priority for patching.

Generated by OpenCVE AI on November 7, 2026 at 12:20 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Quttera ThreatSign to a version newer than 4.1.0.48 to remove the injected user‑agent handling bug
  • If a patch cannot be applied immediately, disable or uninstall the ThreatSign plugin until an updated release is available
  • Apply strict input validation or a web‑application firewall rule to reject or encode malicious User‑Agent headers

Generated by OpenCVE AI on November 7, 2026 at 12:20 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 08 Nov 2026 06:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Sat, 07 Nov 2026 11:30:00 +0000

Type Values Removed Values Added
Description The Quttera ThreatSign – Web Malware Scanner for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'HTTP_USER_AGENT' parameter in all versions up to, and including, 4.1.0.48 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever an administrator accesses an injected page.
Title Quttera ThreatSign <= 4.1.0.48 - Unauthenticated Stored Cross-Site Scripting via User-Agent Header
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.2, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-07T18:05:59.400Z

Reserved: 2026-10-22T21:03:00.835Z

Link: CVE-2026-115548

cve-icon Vulnrichment

Updated: 2026-11-07T17:59:14.267Z

cve-icon NVD

Status : Deferred

Published: 2026-11-07T12:17:42.747

Modified: 2026-11-07T18:17:12.073

Link: CVE-2026-115548

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T12:30:17Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')