Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Unlimited Elements Unlimited Elements For Elementor (Free Widgets, Addons, Templates) unlimited-elements-for-elementor allows Reflected XSS.This issue affects Unlimited Elements For Elementor (Free Widgets, Addons, Templates): from n/a through 2.0.24.
Published: 2026-10-28
Score: 7.1 High
EPSS: n/a
KEV: No
Impact: Cross‑Site Scripting (XSS) that can enable arbitrary script execution in a browser context
Action: Patch Now
AI Analysis

Impact

The vulnerability is a reflected Cross‑Site Scripting flaw where unsanitized input is included in generated web pages. An attacker can craft a URL or input that triggers the plugin to output malicious JavaScript, which will execute in the browsers of any users visiting the affected page. This could lead to session hijacking, credential theft, defacement, or the delivery of malware by exploiting the victim’s privileges.

Affected Systems

WordPress sites running the Unlimited Elements For Elementor (Free Widgets, Addons, Templates) plugin up to and including version 2.0.24 are affected. Any site that has installed this plugin during its lifecycle up to that release is vulnerable.

Risk and Exploitability

The CVSS score of 7.1 indicates a moderate‑to‑high risk. The EPSS score is not available, so the precise exploitation probability is unknown, but the absence from the KEV catalog suggests no widely known active exploitation. Based on the description, the likely attack vector is remote via a crafted request or link that causes the plugin to echo unsanitized data. If an attacker can embed a malicious script into a page that a logged‑in admin or site visitor accesses, the script will run with the victim’s browser privileges.

Generated by OpenCVE AI on October 28, 2026 at 14:23 UTC.

Remediation

Vendor Solution

Update the WordPress Unlimited Elements For Elementor (Free Widgets, Addons, Templates) plugin to the latest available version (at least 2.0.25).


OpenCVE Recommended Actions

  • Update Unlimited Elements For Elementor (Free Widgets, Addons, Templates) to version 2.0.25 or later.
  • If a patch cannot be applied immediately, deactivate or uninstall the plugin to remove the input vector.
  • Ensure that the WordPress core and all other plugins are kept up to date, and use a web‑application firewall to block suspicious script injection attempts.

Generated by OpenCVE AI on October 28, 2026 at 14:23 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 13:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Unlimited Elements Unlimited Elements For Elementor (Free Widgets, Addons, Templates) unlimited-elements-for-elementor allows Reflected XSS.This issue affects Unlimited Elements For Elementor (Free Widgets, Addons, Templates): from n/a through 2.0.24.
Title WordPress Unlimited Elements For Elementor (Free Widgets, Addons, Templates) plugin <= 2.0.24 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-28T13:00:13.871Z

Reserved: 2026-10-23T00:18:53.712Z

Link: CVE-2026-115593

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-28T13:17:04.583

Modified: 2026-10-28T13:46:33.207

Link: CVE-2026-115593

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T14:30:22Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')