Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Stiofan GetPaid invoicing allows Stored XSS.This issue affects GetPaid: from n/a through 2.8.62.
Published: 2026-10-28
Score: 7.1 High
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS) exposing users to malicious script execution
Action: Immediate Patch
AI Analysis

Impact

The vulnerability is a stored cross‑site scripting flaw in the Stiofan GetPaid plugin that arises when the plugin does not properly neutralize user input before persisting it to the database and subsequently rendering it on web pages. An attacker can inject arbitrary JavaScript that will execute in the browsers of visitors who view the affected pages, potentially leading to session hijacking, credential theft, or defacement of displayed content. This weakness aligns with CWE‑79, where unsanitized input is reproduced on output.

Affected Systems

The WordPress GetPaid invoicing plugin from Stiofan, versions from unspecified releases through 2.8.62, is affected. Site owners who have any of those releases installed are susceptible to the stored XSS flaw.

Risk and Exploitability

The CVSS score of 7.1 indicates a medium‑to‑high severity. No EPSS data is available, so the contemporary exploitation probability cannot be quantified, and the vulnerability is not listed in the CISA KEV catalog. The likely attack vector is the plugin’s administrative interface, where an attacker submits crafted input that is stored and later served unfiltered to visitors. While publicly disclosed exploits are not known, the absence of EPSS does not preclude exploitation on high‑traffic sites, making the current threat moderate with the potential to intensify if attackers target vulnerable deployments.

Generated by OpenCVE AI on October 28, 2026 at 14:55 UTC.

Remediation

Vendor Solution

Update the WordPress GetPaid plugin to the latest available version (at least 2.8.63).


OpenCVE Recommended Actions

  • Update the WordPress GetPaid plugin to version 2.8.63 or newer to eliminate the stored XSS flaw
  • If upgrade is not immediately possible, disable or uninstall the plugin to prevent injection of malicious content
  • Deploy a Content Security Policy that restricts inline script execution to mitigate any residual XSS risk

Generated by OpenCVE AI on October 28, 2026 at 14:55 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 13:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Stiofan GetPaid invoicing allows Stored XSS.This issue affects GetPaid: from n/a through 2.8.62.
Title WordPress GetPaid plugin <= 2.8.62 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-28T13:00:11.577Z

Reserved: 2026-10-23T00:18:53.713Z

Link: CVE-2026-115609

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-28T13:17:05.130

Modified: 2026-10-28T13:46:33.207

Link: CVE-2026-115609

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T15:00:25Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')