Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in iova.mihai SliceWP slicewp allows Stored XSS.This issue affects SliceWP: from n/a through 1.2.13.
Published: 2026-10-28
Score: 7.1 High
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Patch Immediately
AI Analysis

Impact

Stored Cross‑Site Scripting is possible in the iova.mihai SliceWP WordPress plugin due to improper neutralization of input during web page generation. An attacker can inject malicious JavaScript or HTML that is saved in the database and then executed by any user who views the affected content. This can lead to credential theft, session hijacking, defacement, or other client‑side attacks, compromising the confidentiality, integrity, and availability of the site for its visitors.

Affected Systems

The SliceWP plugin created by iova.mihai, versions up to and including 1.2.13, is affected. All installations using those versions are vulnerable. Versions starting at 1.2.14 contain the fix and are no longer susceptible to this flaw.

Risk and Exploitability

The CVSS score of 7.1 indicates a high potential impact. EPSS data is not available and the vulnerability is not listed in CISA’s KEV catalog, but the flaw remains exploitable on any site running the affected plugin. The likely attack vector is through the plugin’s content submission or configuration interfaces, which are accessible to administrators or authenticated content authors. By embedding malicious payloads into stored content, an attacker can ensure they run in the browsers of other site visitors.

Generated by OpenCVE AI on October 28, 2026 at 14:54 UTC.

Remediation

Vendor Solution

Update the WordPress SliceWP plugin to the latest available version (at least 1.2.14).


OpenCVE Recommended Actions

  • Update the SliceWP plugin to version 1.2.14 or later.
  • Upgrade the WordPress core and any active themes to their latest versions to reduce other potential attack vectors.
  • If an immediate update is not possible, restrict or disable user roles that can submit or edit plugin content until the vulnerability is patched.

Generated by OpenCVE AI on October 28, 2026 at 14:54 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 28 Oct 2026 13:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in iova.mihai SliceWP slicewp allows Stored XSS.This issue affects SliceWP: from n/a through 1.2.13.
Title WordPress SliceWP plugin <= 1.2.13 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-28T16:07:30.579Z

Reserved: 2026-10-23T00:18:53.713Z

Link: CVE-2026-115612

cve-icon Vulnrichment

Updated: 2026-10-28T14:37:10.754Z

cve-icon NVD

Status : Deferred

Published: 2026-10-28T13:17:05.267

Modified: 2026-10-28T16:17:06.310

Link: CVE-2026-115612

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T15:00:25Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')