Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Advanced Post Block - Post Grid for WordPress block editor advanced-post-block allows Stored XSS.This issue affects Advanced Post Block - Post Grid for WordPress block editor: from n/a through 2.5.1.
Published: 2026-10-26
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Patch
AI Analysis

Impact

Improper neutralization of input in the bPlugins Advanced Post Block - Post Grid for WordPress block editor leads to a stored Cross‑Site Scripting flaw. When a malicious payload is inserted into the plugin’s content—such as within a post or widget—it is persisted in the database and then rendered into the page without sanitization. Any visitor who loads the affected page will have the injected JavaScript executed in their browser, potentially allowing cookie theft, session hijacking, or defacement.

Affected Systems

The vulnerability affects all releases of the bPlugins Advanced Post Block - Post Grid for WordPress block editor up to and including version 2.5.1. Any site running the plugin within that version range is at risk, regardless of the WordPress version or other plugins.

Risk and Exploitability

With a CVSS score of 6.5 the flaw is considered moderate severity. The EPSS score is not available, and it does not appear in the CISA KEV catalog. Attackers would most likely need to inject a payload through an authorized user interface, such as the post editor, and the stored XSS would then affect all visitors who view the modified page. Because the vulnerability is stored, exploitation does not require further user interaction beyond initial content creation.

Generated by OpenCVE AI on October 26, 2026 at 12:22 UTC.

Remediation

Vendor Solution

Update the WordPress Advanced Post Block - Post Grid for WordPress block editor plugin to the latest available version (at least 2.5.2).


OpenCVE Recommended Actions

  • Update the bPlugins Advanced Post Block - Post Grid for WordPress block editor plugin to version 2.5.2 or later.
  • Limit post‑editing capabilities to trusted users only to reduce the chance that malicious input is inserted.
  • Apply a site‑wide Content Security Policy that blocks inline scripts and restricts script execution to trusted origins.

Generated by OpenCVE AI on October 26, 2026 at 12:22 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 26 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Mon, 26 Oct 2026 11:00:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Advanced Post Block - Post Grid for WordPress block editor advanced-post-block allows Stored XSS.This issue affects Advanced Post Block - Post Grid for WordPress block editor: from n/a through 2.5.1.
Title WordPress Advanced Post Block - Post Grid for WordPress block editor plugin <= 2.5.1 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-26T12:54:33.290Z

Reserved: 2026-10-24T00:18:41.993Z

Link: CVE-2026-115955

cve-icon Vulnrichment

Updated: 2026-10-26T12:46:23.049Z

cve-icon NVD

Status : Deferred

Published: 2026-10-26T11:16:36.343

Modified: 2026-10-26T14:16:33.130

Link: CVE-2026-115955

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-26T12:30:10Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')