Description
Missing Authorization vulnerability in WPExperts APIExperts Square for WooCommerce woosquare allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects APIExperts Square for WooCommerce: from n/a through 4.7.5.
Published: 2026-10-26
Score: 5.3 Medium
EPSS: n/a
KEV: No
Impact: Unauthorized access to restricted plugin functionality
Action: Immediate Patch
AI Analysis

Impact

The vulnerability is a missing authorization flaw that allows attackers to exercise functions of the APIExperts Square for WooCommerce plugin that should be protected by access control checks. Because authentication or privilege verification is not performed correctly, an attacker can perform operations intended for privileged users, potentially exposing sensitive data or manipulating commerce transactions.

Affected Systems

Any WordPress installation that has the APIExperts Square for WooCommerce plugin with a version of 4.7.5 or earlier. The flaw is present from the initial feature release through version 4.7.5, affecting all sites that did not upgrade past that release.

Risk and Exploitability

The CVSS score of 5.3 indicates a moderate risk level. EPSS data is not available, and the vulnerability is not listed in CISA’s KEV catalog. The likely attack vector is exploitation of exposed API endpoints that lack proper authorization checks; an attacker may not need elevated privileges to trigger the flaw, depending on configuration. The impact could be unauthorized data access or transaction tampering, with potential confidentiality and integrity consequences.

Generated by OpenCVE AI on October 26, 2026 at 12:21 UTC.

Remediation

Vendor Solution

Update the WordPress APIExperts Square for WooCommerce plugin to the latest available version (at least 4.7.6).


OpenCVE Recommended Actions

  • Update WordPress APIExperts Square for WooCommerce to version 4.7.6 or later to incorporate the fix.
  • Re‑evaluate the plugin’s permission settings to ensure only authorized roles can access sensitive functions.
  • Monitor site logs for unexpected API calls and consider deploying additional security plugins to harden access control.

Generated by OpenCVE AI on October 26, 2026 at 12:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 26 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Mon, 26 Oct 2026 11:00:00 +0000

Type Values Removed Values Added
Description Missing Authorization vulnerability in WPExperts APIExperts Square for WooCommerce woosquare allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects APIExperts Square for WooCommerce: from n/a through 4.7.5.
Title WordPress APIExperts Square for WooCommerce plugin <= 4.7.5 - Broken Access Control vulnerability
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 5.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-26T12:54:32.987Z

Reserved: 2026-10-24T00:18:41.994Z

Link: CVE-2026-115959

cve-icon Vulnrichment

Updated: 2026-10-26T12:46:12.410Z

cve-icon NVD

Status : Deferred

Published: 2026-10-26T11:16:36.720

Modified: 2026-10-26T14:16:33.370

Link: CVE-2026-115959

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-26T12:30:10Z

Weaknesses