Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins B Slider b-slider allows Stored XSS.This issue affects B Slider: from n/a through 2.2.2.
Published: 2026-10-26
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The vulnerability is a stored cross‑site scripting flaw caused by improper neutralization of user input in the B Slider plugin. When an attacker injects malicious JavaScript through a field that the plugin stores and later displays, the code will run in the browser context of any visitor to the affected site. The impact is primarily loss of confidentiality and potential credential theft or defacement, but it does not provide direct remote code execution on the server.

Affected Systems

WordPress users who have installed bPlugins B Slider versions up to and including 2.2.2 are affected. Versions earlier than the listed starting point (N/A) are also included because the vulnerability is present without a specific lower bound. The plugin is distributed as part of the WordPress plugin ecosystem, and any site using it without patching presents the risk.

Risk and Exploitability

The CVSS score of 6.5 categorises the weakness as moderate severity. The EPSS score is unavailable, so the likelihood of exploitation is not quantified here. The vulnerability is not listed in the CISA KEV catalog, indicating no confirmed active exploitation at the time of this analysis. The likely attack vector is through the plugin's administrative interface, where an attacker can submit malicious payloads that are then rendered in the public site. Successful exploitation requires access to a user account with permission to create or edit slider content.

Generated by OpenCVE AI on October 26, 2026 at 12:50 UTC.

Remediation

Vendor Solution

Update the WordPress B Slider plugin to the latest available version (at least 2.2.4).


OpenCVE Recommended Actions

  • Update the WordPress B Slider plugin to version 2.2.4 or later. This patch removes the stored XSS vulnerability.
  • Limit permission to create or edit slider content to trusted administrators; revoke excessive editing rights that could allow injection of malicious scripts.
  • If an immediate update is not possible, disable or remove the B Slider plugin from sites that do not require it to prevent exposure to the vulnerability.

Generated by OpenCVE AI on October 26, 2026 at 12:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 26 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Mon, 26 Oct 2026 11:00:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins B Slider b-slider allows Stored XSS.This issue affects B Slider: from n/a through 2.2.2.
Title WordPress B Slider plugin <= 2.2.2 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-26T12:54:33.589Z

Reserved: 2026-10-24T00:18:41.994Z

Link: CVE-2026-115961

cve-icon Vulnrichment

Updated: 2026-10-26T12:46:33.556Z

cve-icon NVD

Status : Deferred

Published: 2026-10-26T11:16:36.987

Modified: 2026-10-26T14:16:33.590

Link: CVE-2026-115961

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-26T13:00:14Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')