Description
A weakness has been identified in DedeCMS up to 5.7.118. Impacted is the function require_once of the file dede/update_guide.php. This manipulation of the argument vtime causes code injection. Remote exploitation of the attack is possible. The exploit has been made available to the public and could be used for attacks.
Published: 2026-10-25
Score: 5.1 Medium
EPSS: n/a
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

A vulnerability exists in DedeCMS, affecting versions up to 5.7.118, where the require_once call inside dede/update_guide.php can be manipulated by altering the vtime argument. This allows an attacker to inject code that is executed on the server, enabling full remote code execution. The weakness stems from improper handling of special characters (CWE‑74) and improper control of code generation (CWE‑94). Remote exploitation is possible because the vulnerable function is exposed via web requests.

Affected Systems

The affected product is DedeCMS, versions up to and including 5.7.118. The issue impacts the function require_once in the update_guide.php module, regardless of specific deployment configurations, as the vulnerable code is present in all installations of the affected versions.

Risk and Exploitability

The CVSS score of 5.1 indicates a moderate severity, but the disclosure of public proof‑of‑concept code raises the threat level. The EPSS score is not available, making it difficult to gauge current exploitation density, and the vulnerability is not listed in the CISA KEV catalog. Based on the description, the likely attack vector is remote HTTP requests that supply a crafted vtime parameter. If successfully exploited, an attacker can execute arbitrary code on the web server with the privileges of the underlying application.

Generated by OpenCVE AI on October 25, 2026 at 21:31 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade to a DedeCMS release newer than 5.7.118 that removes or secures the vulnerable require_once usage.
  • If an upgrade cannot be performed immediately, delete or shield the update_guide.php file from web exposure to block the code injection pathway.
  • Deploy a web application firewall or equivalent filtering rule to validate the vtime parameter, ensuring it only accepts numeric timestamps and preventing arbitrary file inclusion attempts.

Generated by OpenCVE AI on October 25, 2026 at 21:31 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 25 Oct 2026 20:30:00 +0000

Type Values Removed Values Added
Description A weakness has been identified in DedeCMS up to 5.7.118. Impacted is the function require_once of the file dede/update_guide.php. This manipulation of the argument vtime causes code injection. Remote exploitation of the attack is possible. The exploit has been made available to the public and could be used for attacks.
Title DedeCMS update_guide.php require_once code injection
First Time appeared Dedecms
Dedecms dedecms
Weaknesses CWE-74
CWE-94
CPEs cpe:2.3:a:dedecms:dedecms:*:*:*:*:*:*:*:*
Vendors & Products Dedecms
Dedecms dedecms
References
Metrics cvssV2_0

{'score': 5.8, 'vector': 'AV:N/AC:L/Au:M/C:P/I:P/A:P/E:POC/RL:ND/RC:C'}

cvssV3_0

{'score': 4.7, 'vector': 'CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L/E:P/RL:X/RC:C'}

cvssV3_1

{'score': 4.7, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L/E:P/RL:X/RC:C'}

cvssV4_0

{'score': 5.1, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P'}


cve-icon MITRE

Status: PUBLISHED

Assigner: VulDB

Published:

Updated: 2026-10-25T17:45:12.345Z

Reserved: 2026-10-24T21:46:16.650Z

Link: CVE-2026-116063

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-25T18:16:47.110

Modified: 2026-10-25T18:16:47.110

Link: CVE-2026-116063

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-25T21:45:06Z

Weaknesses
  • CWE-74

    Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')

  • CWE-94

    Improper Control of Generation of Code ('Code Injection')