Description
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Magepeople inc. WpEvently mage-eventpress allows Code Injection.This issue affects WpEvently: from n/a through 5.7.9.
Published: 2026-10-26
Score: 5.3 Medium
EPSS: n/a
KEV: No
Impact: Cross‑Site Scripting
Action: Patch
AI Analysis

Impact

The vulnerability is a basic cross‑site scripting flaw caused by improper neutralization of script‑related HTML tags. An attacker can insert arbitrary JavaScript into content handled by the WpEvently plugin, leading to execution in the browsers of visitors or administrators. This can compromise user sessions, steal credentials, or deface the site. The weakness is classified as CWE‑80.

Affected Systems

The flaw affects the WordPress WpEvently plugin from Magepeople Inc. Versions up to and including 5.7.9 are vulnerable. Any WordPress installation using these plugin versions is at risk.

Risk and Exploitability

The CVSS score of 5.3 indicates a moderate impact. The EPSS score is not available, and the vulnerability is not listed in the CISA KEV catalog, suggesting no confirmed widespread exploitation. Based on the description, it is inferred that the likely attack vector involves input fields within the plugin that are rendered without proper sanitization, allowing an attacker to inject scripts that run in the context of legitimate users. Consequently, the risk is moderate to high for sites that do not restrict admin access or that expose the plugin content to visitors.

Generated by OpenCVE AI on October 26, 2026 at 17:51 UTC.

Remediation

Vendor Solution

Update the WordPress WpEvently plugin to the latest available version (at least 5.7.10).


OpenCVE Recommended Actions

  • Upgrade the WordPress WpEvently plugin to version 5.7.10 or later.
  • If an immediate upgrade is not possible, disable the plugin or restrict access to its content until the patch is applied.
  • Implement a web application firewall rule that blocks attempts to inject script tags into plugin data fields.

Generated by OpenCVE AI on October 26, 2026 at 17:51 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 26 Oct 2026 18:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Mon, 26 Oct 2026 16:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Magepeople inc. WpEvently mage-eventpress allows Code Injection.This issue affects WpEvently: from n/a through 5.7.9.
Title WordPress WpEvently plugin <= 5.7.9 - Content Injection vulnerability
Weaknesses CWE-80
References
Metrics cvssV3_1

{'score': 5.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-26T17:37:11.529Z

Reserved: 2026-10-26T10:03:13.834Z

Link: CVE-2026-116394

cve-icon Vulnrichment

Updated: 2026-10-26T17:35:50.468Z

cve-icon NVD

Status : Deferred

Published: 2026-10-26T16:17:18.547

Modified: 2026-10-26T18:35:08.450

Link: CVE-2026-116394

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-26T18:00:08Z

Weaknesses
  • CWE-80

    Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)