Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins LightBox Block lightbox-block allows Stored XSS.This issue affects LightBox Block: from n/a through 1.2.0.
Published: 2026-10-26
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS) that can execute arbitrary client‑side code
Action: Patch
AI Analysis

Impact

The vulnerability arises from improper neutralization of user input during web page generation. It allows an attacker to inject malicious script that is stored by the LightBox Block plugin and subsequently executed in visitors’ browsers. This stored XSS can be used to deface the site, steal session cookies, or install malware on end‑users. The weakness corresponds to CWE‑79, a classic example of input validation failure.

Affected Systems

This flaw affects the bPlugins LightBox Block plugin for WordPress, impacting all installations that use any version from the initial release up through version 1.2.0. Users of earlier or later releases are not affected. The plugin is used to embed image galleries and lightbox functionality within posts and pages.

Risk and Exploitability

The CVSS v3 score of 6.5 indicates a moderate‑impact vulnerability. EPSS is not available, so the current exploit probability is unknown, and the issue is not listed in the CISA KEV catalog. The likely attack vector is a stored XSS, where a malicious administrator or trusted user can insert script into the block’s content field. Once injected, the code would run in the browser of any visitor viewing the affected content, potentially compromising user credentials and the integrity of the site.

Generated by OpenCVE AI on October 26, 2026 at 18:39 UTC.

Remediation

Vendor Solution

Update the WordPress LightBox Block plugin to the latest available version (at least 1.2.1).


OpenCVE Recommended Actions

  • Upgrade the LightBox Block plugin to version 1.2.1 or later, which removes the stored XSS flaw.
  • If an upgrade is not immediately possible, uninstall the plugin to eliminate the attack surface until a patch can be applied.
  • Review existing LightBox block content for injected scripts and sanitize or delete any malicious entries before re‑deploying.

Generated by OpenCVE AI on October 26, 2026 at 18:39 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 26 Oct 2026 18:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Mon, 26 Oct 2026 17:00:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins LightBox Block lightbox-block allows Stored XSS.This issue affects LightBox Block: from n/a through 1.2.0.
Title WordPress LightBox Block plugin <= 1.2.0 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-26T17:37:09.389Z

Reserved: 2026-10-26T10:03:13.834Z

Link: CVE-2026-116395

cve-icon Vulnrichment

Updated: 2026-10-26T17:34:39.682Z

cve-icon NVD

Status : Deferred

Published: 2026-10-26T17:17:26.653

Modified: 2026-10-26T18:35:08.450

Link: CVE-2026-116395

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-26T18:45:14Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')