Impact
The Like Button Rating ♥ LikeBtn WordPress plugin permits unauthenticated attackers to insert arbitrary JavaScript into the database via the 'Client-IP' HTTP header when the site administrator has disabled the 'Be GDPR compliant' option. The unsanitized header value is stored without escaping, so any visitor who loads a page containing the stored IP will execute the injected code. This stored cross‑site scripting vulnerability (CWE‑79) can lead to session hijacking, defacement, or delivery of malware.
Affected Systems
All installations of the Like Button Rating ♥ LikeBtn plugin for WordPress up to and including version 2.6.64 are vulnerable. Earlier releases and the patched 2.6.65 and newer versions are not affected.
Risk and Exploitability
With a CVSS score of 4.7 the flaw is considered medium severity, and no EPSS data is available. Because a successful attack depends on the administrator disabling the 'Be GDPR compliant' setting, exploitation is limited to sites misconfigured in that way. The vulnerability is not listed in the CISA KEV catalog, indicating it is not presently known to be actively exploited.
OpenCVE Enrichment