Description
The Advanced Members for ACF plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 1.3.0 via the `acf[_amem_local_user_password]` parameter of the `[advanced-members-account-password]` shortcode form submission. This is due to a PHP operator-precedence bug in the `pre_update_value` function of `acf/fields/class-user-password.php` that assigns boolean `true` instead of the resolved user ID to `$user_id`, causing the `_can_edit()` authorization check to pass for any logged-in user via PHP loose equality, and causing `wp_update_user()` to cast `'ID' => true` to integer `1` — unconditionally targeting the primary administrator account. This makes it possible for authenticated attackers, with Subscriber-level access and above, to overwrite the password of user ID 1 (the site's primary administrator) with an attacker-chosen value, granting full administrative access to the site. The intended exclusion guard in `Account::process` that strips the password field before saving is defeated because `amem_save_all_fields()` re-reads the full field list from `amem()->submission` and silently overwrites the caller-supplied excluded fields array with an empty array, ensuring the password field is always processed.
Published: 2026-11-06
Score: 8.8 High
EPSS: n/a
KEV: No
Impact: Privilege Escalation
Action: Immediate Patch
AI Analysis

Impact

The Advanced Members for ACF plugin contains a PHP operator‑preference bug that causes the user ID used in a password change form to resolve to the boolean true. The resulting authorization check passes for any logged‑in user, and the subsequent wp_update_user call casts the ID to integer 1, forcing the primary administrator account’s password to be overwritten. An attacker with the minimum Subscriber role can therefore supply a new password value in the acf[_amem_local_user_password] field of the [advanced-members-account-password] shortcode form and obtain full administrative control of the WordPress site. This is a classic privilege‑escalation flaw (CWE‑269) that directly compromises confidentiality, integrity and availability by allowing unauthorized modification of the site’s master account.

Affected Systems

The flaw affects all WordPress deployments running Advanced Members for ACF version 1.3.0 or earlier. The plugin is distributed as an open‑source WordPress add‑on, so any site using the listed version range is susceptible. No specific operating‑system or PHP version is required beyond the standard WordPress environment.

Risk and Exploitability

With a CVSS score of 8.8 the vulnerability is considered high severity. The exploit path is straightforward: a logged‑in user simply submits the password change form with the injected parameter; no additional privileges or network access are required beyond normal subscriber access. The EPSS score is not available, but because the code is publicly visible and the vulnerability is easy to use, the likelihood of exploitation remains significant. Although the vulnerability is not listed in the CISA “Known Exploited Vulnerabilities” catalog, the easy attack surface and the fact that the attack targets the primary administrator means that attackers who have compromised a site can gain full control quickly.

Generated by OpenCVE AI on November 6, 2026 at 12:23 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Apply the latest version of the Advanced Members for ACF plugin that removes the operator‑precedence bug.
  • If an update is not yet available, restrict the account‑password shortcode to administrator‑only roles or remove the shortcode entirely from subscriber‑accessible pages.
  • As a temporary measure, modify or disable the pre_update_value filter so that the _can_edit check receives the correct user ID, preventing the cast to the administrator ID.

Generated by OpenCVE AI on November 6, 2026 at 12:23 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 06 Nov 2026 11:30:00 +0000

Type Values Removed Values Added
Description The Advanced Members for ACF plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 1.3.0 via the `acf[_amem_local_user_password]` parameter of the `[advanced-members-account-password]` shortcode form submission. This is due to a PHP operator-precedence bug in the `pre_update_value` function of `acf/fields/class-user-password.php` that assigns boolean `true` instead of the resolved user ID to `$user_id`, causing the `_can_edit()` authorization check to pass for any logged-in user via PHP loose equality, and causing `wp_update_user()` to cast `'ID' => true` to integer `1` — unconditionally targeting the primary administrator account. This makes it possible for authenticated attackers, with Subscriber-level access and above, to overwrite the password of user ID 1 (the site's primary administrator) with an attacker-chosen value, granting full administrative access to the site. The intended exclusion guard in `Account::process` that strips the password field before saving is defeated because `amem_save_all_fields()` re-reads the full field list from `amem()->submission` and silently overwrites the caller-supplied excluded fields array with an empty array, ensuring the password field is always processed.
Title Advanced Members for ACF <= 1.3.0 - Authenticated (Subscriber+) Privilege Escalation via Account Change-Password Form
Weaknesses CWE-269
References
Metrics cvssV3_1

{'score': 8.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-06T11:17:38.056Z

Reserved: 2026-10-26T17:25:03.004Z

Link: CVE-2026-116624

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-06T12:17:17.340

Modified: 2026-11-06T12:17:17.457

Link: CVE-2026-116624

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-06T12:30:04Z

Weaknesses
  • CWE-269

    Improper Privilege Management