Description
The CMB2 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'cmb43ex1_grp[0][txt] (wysiwyg field inside group — field id controlled by integrator config)' parameter in all versions up to, and including, 2.13.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable when a site integrator renders the plugin's documented front-end form helper with a wysiwyg field inside a repeatable group on a publicly accessible page.
Published: 2026-10-28
Score: 5.4 Medium
EPSS: n/a
KEV: No
Impact: Stored XSS leading to arbitrary script execution on visitors' browsers
Action: Patch Now
AI Analysis

Impact

The CMB2 plugin for WordPress is vulnerable to Stored Cross‑Site Scripting because the WYSIWYG field inside a repeatable group is not properly sanitized or escaped. An attacker can inject malicious JavaScript into the parameter that controls the field ID, causing the script to execute for any user who views a page that renders the injected content. This type of persistence does not require user authentication to post the payload but can compromise confidentiality and integrity of the site by enabling credential theft, defacement, or injection of malware into the browsing session.

Affected Systems

All WordPress sites using the CMB2 plugin version 2.13.4 or earlier are affected. The vulnerability applies when a site integrator renders the plugin’s documented front‑end form helper with a WYSIWYG field inside a repeatable group on a publicly accessible page. The specific product is the jtsternberg CMB2 plugin, and any public site that includes such a form is at risk.

Risk and Exploitability

The CVSS score is 5.4, indicating a moderate severity. No EPSS information is available, and the vulnerability is not listed in CISA’s KEV catalog, suggesting that it has not yet been widely exploited in the wild. However, because the attack vector involves unauthenticated submission of user‑controlled data into a publicly exposed form, the exploitation likelihood remains realistic in environments that expose such forms. If the injected script runs, it can compromise all visitors to the affected pages.

Generated by OpenCVE AI on October 28, 2026 at 09:07 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the CMB2 plugin to a version newer than 2.13.4 that implements proper sanitization and escaping for group WYSIWYG fields.
  • If an update is not possible, remove or disable the front‑end form helper that contains the vulnerable group field, or reconfigure the plug‑in to exclude a WYSIWYG field from any repeatable group rendered on public pages.
  • Apply custom sanitization or use WordPress’s wp_kses to escape all output of the vulnerable field before it is rendered.
  • Consider implementing a Content Security Policy to mitigate the impact of any residual XSS payloads.

Generated by OpenCVE AI on October 28, 2026 at 09:07 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 10:00:00 +0000

Type Values Removed Values Added
First Time appeared Jtsternberg
Jtsternberg cmb2
Wordpress-extensions
Wordpress-extensions cmb2
Vendors & Products Jtsternberg
Jtsternberg cmb2
Wordpress-extensions
Wordpress-extensions cmb2

Wed, 28 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The CMB2 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'cmb43ex1_grp[0][txt] (wysiwyg field inside group — field id controlled by integrator config)' parameter in all versions up to, and including, 2.13.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable when a site integrator renders the plugin's documented front-end form helper with a wysiwyg field inside a repeatable group on a publicly accessible page.
Title CMB2 <= 2.13.4 - Unauthenticated Stored Cross-Site Scripting via Grouped WYSIWYG Field via Front-End Form
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 5.4, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

Jtsternberg Cmb2
Wordpress-extensions Cmb2
cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T06:45:17.138Z

Reserved: 2026-10-26T21:12:28.214Z

Link: CVE-2026-116761

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T07:16:47.893

Modified: 2026-10-28T07:16:47.893

Link: CVE-2026-116761

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T09:45:17Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')